Ask Your Question

Why does the install install in the language of my location. [closed]

asked 2014-03-26 02:21:19 +0200

gregors gravatar image

updated 2015-09-09 20:41:50 +0200

Alex Kemp gravatar image

I want LibreOffice to display menus, etc. in English. I live in, and my computer is located in, Sweden. I do however not want the GUI to be in Swedish (though I do want Swedish spelling correction to be available). There should be a 'switch' for these alternatives in the 'Advanced' install (maybe there is but it was not immediately obvious.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-20 15:33:00.326734

2 Answers

Sort by » oldest newest most voted

answered 2014-03-26 11:15:05 +0200

akerbeltzalba gravatar image

It's the highly counter-intuitive way in which the language options work. You can only switch between the languages the installer (either automatic or manual) installed. Usually that takes the UI language from your computer's locale. So if you only installed Swedish, in order to get the English UI or the Spanish UI, you have to run the installer again. Crazy, I know but it's some inherited code/process.

Have a look at this step by step guide we wrote (it's for Gaelic but the process is the same)

edit flag offensive delete link more

answered 2014-03-26 02:29:54 +0200

m.a.riosv gravatar image

Menu/Tools/Options/Language settings/Languages - User Interface

edit flag offensive delete link more


According from the answers above there may be two issues:
a) Installation program runs in Swedish. (I think this can't be fixed at least I was not successfully doing it).
b) After installation the LibreOffice GUI is in non-English language. GUI language can be changed as mariousv has written.

L-user gravatar imageL-user ( 2014-03-27 14:06:11 +0200 )edit

Question Tools

1 follower


Asked: 2014-03-26 02:21:19 +0200

Seen: 155 times

Last updated: Mar 26 '14