Ask Your Question
0

Writer: VERY large fonts not "displaying properly" [closed]

asked 2014-04-29 12:58:09 +0200

Popper gravatar image

updated 2015-09-27 18:48:16 +0200

Alex Kemp gravatar image

I am creating some signage and have a 720pt font. Each page is 10.5"x8" landscape. (1/4" border all around) I will put as many large characters per page as will fit, print them out, and tape them together.

The problem is, the character has a large spacing at the top, and the bottom of the character is off the page.

Is there a way to make it stop doing this? I want the characters centered within the page vertically.

I didn't want to have to create a text object, or anything like that. Although it might have a similar issue with the way it is formatting the characters.

I tried setting Format Paragraph Line Spacing to Fixed, but it only allows a max value of 3.94". And I set Spacing Above Paragraph to 3.94" (max again) and the characters are pretty much in the correct location, but the tops are cut off.

I'm sure I've done this before in an older version of LibreOffice. (maybe something changed?)

Any ideas or suggestions?

Latest LibreOffice Version: 4.2.3.3 Windows 7 Home Premium 64bit SP1

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-21 20:13:46.536817

2 Answers

Sort by » oldest newest most voted
0

answered 2014-04-30 23:45:32 +0200

horst gravatar image

I tried Calc. 1 character per cell and formated the cell 10" height and 8" wide and it works better than in Writer. You have to use 1character per cell and format the page to your settings, no header or footer.

Not as pretty as in Writer but it works.

It looks like writer has a bug there, Word 2010 starter does a much better job, but still cuts off the bottom even with 72pt.

edit flag offensive delete link more
0

answered 2014-04-30 15:46:09 +0200

oweng gravatar image

The problem is, the character has a large spacing at the top, and the bottom of the character is off the page.

Try using a different font with a larger x-height or smaller leading. Here is a capital A in 36, 72, 144, and 288 pt sizes, in Linux Libertine G, DejaVu Sans Mono, and Source Code Pro, each with a pale grey background for clarity:

different font leading

Notice the greater spacing above and below the A in Source Code Pro? This is a font metric set by the font designer for a specific purpose. It can be overridden by using a fixed line height value that is smaller than the default Single value (~117.5% of the point size), although the largest value this field can take appears to be 283.5 pt.

edit flag offensive delete link more

Comments

Thanks. I did try different fonts, in case the font I was using (Calibri) had some odd thing about it, like some do, and they all pretty much work the same. The only "answer" I've found is that you are limited to the point size of the font you can use. The maximum size seems to be (about) 432, which is only about half the page size. That's 6 times 72 pt, which is supposed to be 1", so they should be 6" tall, but they are actually only about 4" tall, so I'm not sure what's going on there.

Popper gravatar imagePopper ( 2014-04-30 20:22:36 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2014-04-29 12:58:09 +0200

Seen: 1,592 times

Last updated: Apr 30 '14