Ask Your Question
0

I am trying to update to 4.24. The installer says I must log in as administrator. I am logged in as administrator. How can I get the installer to recognize this? [closed]

asked 2014-05-13 21:57:52 +0200

kb.gardener gravatar image

updated 2015-09-27 18:47:39 +0200

Alex Kemp gravatar image

LibreOffice 4.24, ENG, installer (common) Windows 7 Home Premium, Service Pack 1, English, 64 bit

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2016-02-22 16:48:53.284335

Comments

right-click on the file, select "execute as admintrator"

Mano Engel gravatar imageMano Engel ( 2014-05-13 22:41:35 +0200 )edit

You could also try lowering the UAC settings. That's in Control Panel, User Accounts, Change User Account Control Settings, Change the setting on the slider to Never Notify (take note of where it is). Okay your way out. You will then have to restart the computer for the settings to take place. Then try the install. Whether it works or not, remember to set the UAC setting back to where it was.

Rugslug gravatar imageRugslug ( 2014-05-13 22:55:20 +0200 )edit

From a security perspective, it is not very wise, but if the UAC stops LO from installing, then you have to lower it. I have Win 7 32-bit, and I lower it in order to have LO install. The UAC asks if you want to install a program, so with it lowered you will not be prompted for software installations (a security feature most users were annoyed with when Vista came out with it). Hence, after installing LO (or not), return the UAC to the higher setting for security purposes and restart.

Rugslug gravatar imageRugslug ( 2014-05-14 04:12:23 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-05-14 04:10:45 +0200

I am having a similar problem installing on Win 8.1 64bit. The installer deleted the old version except for a folder called progrAm under libreoffice. It is read/write protected and there is no way to remove it so the installer can proceed.

I tried running as Admin and still same issue.

edit flag offensive delete link more

Comments

With Win 7 (I'll assume it would be the same with Win 8), Right click on your "Program" folder, Properties, uncheck the Read Only Box. Okay out. You may need to do the same thing for subfolders (I'm not testing this to see what happens on my installation). Then maybe you will be able to delete the program folder and sub-folders.

Rugslug gravatar imageRugslug ( 2014-05-15 01:21:14 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2014-05-13 21:57:52 +0200

Seen: 567 times

Last updated: May 14 '14