Ask Your Question

Page Count Decrements in Large Plain Doc [closed]

asked 2014-05-16 01:13:02 +0200

computersbyira gravatar image

updated 2015-09-27 18:47:14 +0200

Alex Kemp gravatar image

I have a customer who's been writing a book for awhile. He's up to 800+ pages of plain text--no images whatsoever--mostly written in Microsoft Office. Now I've supplied him with two new computers running Windows Seven 64-bit, and because the MS Office version he was using was ancient, we opted to go with the latest version of LO (4.2.4). But it's doing some pretty weird stuff with just his large documents.

When my customer opens his document, it takes a LONG time to load up. Like, a second per page. Then, as the page count in the bottom-left gets to the two-hundreds, it begins to decrement...counting backwards! The latest report is that, if left completely alone, it will finally load all the way up...after about 15 minutes...and he's able to navigate throughout the document as he pleases.

Perhaps related...within thirty seconds of opening the document, Windows Live Mail will suddenly start up. We'll minimize or close it, and LibreOffice will have a notification window telling us it couldn't send an email. But...we didn't want to send an email. We have NO IDEA how this is getting triggered.

We have tried different file types: .doc, .docx, .odf.--no change. We've checked the memory options: set at 20MB, and document isn't even quite 4GB yet.

Any assistance will be greatly appreciated! This poor man doesn't ask for much, just a cheap laptop on which he can write a book while sitting on his deck in peace. :-)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-22 17:38:40.123695

2 Answers

Sort by » oldest newest most voted

answered 2014-05-16 15:26:48 +0200

petermau gravatar image

updated 2014-05-16 16:50:12 +0200

I have only used LibO with books up to 250 pages but with a number of images. Of course it also depends how big the pages are and how much text is on each page and whether you are using styles or manual formatting..However:

If you are creating a large document, either lots of pages or including a number of images, it is always prudent to up the memory settings. For 800 pages make the memory as large as possible. The settings are in Tools > Options > Memory. The default settings are appropriate for typical documents. You say that your setting is 20MB which is not large enough. If you do not have enough memory the systems will slow drastically and spend all its time managing the limited memory available. Increasing the memory is one of the first things I do when installing a new system. You do not say you have tried saving the document as a .odt file and working on this version. Whether this helps the page numbering is an interesting question..... Peter

edit flag offensive delete link more


Okay, we'll try that. Thanks for the suggestion! I'll let you know what happens...

computersbyira gravatar imagecomputersbyira ( 2014-05-17 00:04:33 +0200 )edit

Increasing the memory + switching to .odt format fixed the problems! Loads decently now, no more weird page number decrementing, and Windows Mail seems to have been a coincidental thing. Thanks, everyone!

computersbyira gravatar imagecomputersbyira ( 2014-05-17 02:26:31 +0200 )edit

answered 2014-05-16 07:08:09 +0200

ROSt52 gravatar image

updated 2014-05-16 10:55:41 +0200

800 page in one file! I can't believe.

I would do the following:
- Learn how to create a Master Document
- Create a master document
- Open the 800 page file once again (keep a safety copy!!!)
- Break down the file into pieces; maybe along chapters
- Import the new files into the master file.
- Safe always in odt-format; others only at the very(!) end.

You find the documentation here:

edit flag offensive delete link more


@ROSt52 This is the right suggestion for an 800 page document with LO. But OP says his customer simply wants to write a book. If he can accompany his customer through the whole process it's OK, but if the writer will be left alone with Master Documents it is not a good idea. Unfortunately, the implementation of Master Documents in LO is messy and causes many headaches.

lonoob gravatar imagelonoob ( 2014-05-16 12:24:59 +0200 )edit

I know, my jaw dropped too at 800 pages! If adjusting the memory does nothing, we try a variation of your suggestion: cut and paste sections/chapters into separate documents. We'll also try using the .odt format. This fellow is not tech-savvy...only recently got him off floppy I want to keep things as simple and straight-forward as possible. Thanks again for your help, all! Will keep you apprised...

computersbyira gravatar imagecomputersbyira ( 2014-05-17 00:08:28 +0200 )edit

Question Tools



Asked: 2014-05-16 01:13:02 +0200

Seen: 226 times

Last updated: May 16 '14