Ask Your Question
0

Calc: Disabling auto-update and auto-"range correction" of diagrams [closed]

asked 2014-05-19 18:02:41 +0200

blubb444 gravatar image

updated 2015-09-27 18:46:48 +0200

Alex Kemp gravatar image

I have a sheet with a huge diagram here that I update in irregular intervals (3 sets of several ten thousands of weather values that grow over time) Now whenever I go into the diagram to change the ranges, I have to manually set the new X and Y ranges for all 3 sets. Now here come the problems:

image description

  • As soon as I have edited one of the 6 ranges I want to edit, I have to wait about a minute because the change I made is apparently applied "live" to the diagram (which as I said is huge and will grow bigger). Can I change Calc's behaviour so that the changes are only applied to the diagram as soon as I hit the OK button? (i.e. disabling "auto-update as I type")
  • I also would like to be able to select a bigger range for the diagram in advance than what actual data I currently have in the sheet, but when I for example enter "70000" it automatically "corrects" to "64531" (see image) because I don't have that much data yet. Is it possible to disable this "auto-correction" so that I can simply put in a higher number (maybe even 200000), leaving the diagram at these still non-existent values blank and when the new data is entered to the sheet, I can easily "refresh" the diagram? As it currently is I always have to manually update the ranges in the diagram whenever new data comes in, which is somewhat annoying EDIT: Oh forgot, version is 4.2.4.2 on Win7 x64 Home Premium, both in German
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-23 02:02:32.425559

1 Answer

Sort by » oldest newest most voted
0

answered 2014-05-19 23:24:37 +0200

m.a.riosv gravatar image
edit flag offensive delete link more

Comments

Well, I can't drag/drop the data range like suggested because the sets are in non-neighbouring rows, as has been pointed out in your first link. But I did find a workaround for my second issue in the meantime (should've thought about it earlier): I simply went to column 200000 and entered some "dummy data" there, now it doesn't revert to the smaller range any more. Still, the instant auto-update when modifying ranges should be able to be turned off, as it is very CPU-intensive

blubb444 gravatar imageblubb444 ( 2014-05-20 02:33:31 +0200 )edit

I don't know how your data are, but maybe a first data resume with pivot table could help to reduce the data number for chart.

m.a.riosv gravatar imagem.a.riosv ( 2014-05-20 02:55:37 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2014-05-19 18:02:41 +0200

Seen: 277 times

Last updated: May 19 '14