Ask Your Question
1

How can I make the default AutoCorrect work? (ellipsis, em dash, arrows...) [closed]

asked 2014-05-25 14:47:20 +0200

ciencisto gravatar image

updated 2015-09-05 13:29:01 +0200

Alex Kemp gravatar image

I'm using LibreOffice Writer 4.2.4.2 Fedora edition.

When I type '...', it is not automatically replaced with '…' in Fedora 20, whereas it is in Ubuntu 14.04 with slightly older version of the software.

Same thing with replacing '---' with '—', '-->' with '→' etc.

The default language is set to French (Canada), and I checked and I do have the libreoffice-langpack-fr and autocorr-fr packages installed. The auto correction works if I manually add all the entries in DocumentList.xml found in /usr/share/autocorr/acor-fr-FR.dat . However, it is quite painfully long to do...

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-24 21:07:08.386823

1 Answer

Sort by » oldest newest most voted
0

answered 2014-06-05 12:34:00 +0200

Beizerno gravatar image

updated 2014-06-05 12:41:11 +0200

Salut: pour la révision et l'autocorrection en français, il y a l'extension Grammalecte, module très intéressant de correction grammaticale pour le français.

For French grammar checker and autocorrection, you can use Grammalecte:

See: https://forum.openoffice.org/fr/forum...

Grammalecte: http://www.dicollecte.org/grammalecte/


By the way, automatic ellipsis mark is a problem with LibreOffice. Writing both in French and Spanish, if I write 3 dots "..." AutoCorrect replaces it by a real ellipsis mark "…" ONLY if there is a space before. But if I put the dots after a word (which is the case most of the time) the AutoCorrect doesn't work.

If someone knows how to fix this without using extension, would be great to know.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2014-05-25 14:47:20 +0200

Seen: 893 times

Last updated: Jun 05 '14