Ask Your Question
0

Quickstarter icon doesn't show under Unity

asked 2014-06-17 19:49:50 +0100

updated 2015-09-04 13:21:30 +0100

Alex Kemp gravatar image

I am running Ubuntu 14.04 x64, have Quickstarter enabled and it seems working, only problem is the indicator icon for it is missing from the system tray.

edit retag flag offensive close merge delete

Comments

Me too, but I never bothered to check it out. (Unity ... not my favourite bit of Ubuntu!) There could be a related bug reported for KDE/Kubuntu (fdo#72243) - does the work-around suggested in Comment 1 help? (I can't check just now.)

David gravatar imageDavid ( 2014-06-17 20:36:09 +0100 )edit

It doesn't work with both libreoffice-gnome and libreoffice-gtk being installed.

Inoki gravatar imageInoki ( 2014-06-19 05:51:18 +0100 )edit
1

Removing libreoffice-gnome or libreoffice-gtk would not be good idea - then also part of LibreOffice functionality will be removed. Also there are some dependencies. Under LXDE this quickstarter icon is working and both of the mentioned packages are installed. Besides - also under Unity 2D the quickstart icon does not appear. But still soffice.bin and oosplash processes appears to be working. I compared here Ubuntu and Lubuntu 14.04 with all updates at current day.

Edmund Laugasson gravatar imageEdmund Laugasson ( 2015-02-24 16:48:13 +0100 )edit

After @EdmundLaugasson's helpful comment, I looked at the bug reports again, and saw his addition to fdo#77936 "When enable QuickStarter in Ubuntu Unity, there is no systray in the notification area", and it is still a problem in 4.4.1.2. (Ubuntu 14.04 LTS, x64). Good to keep this on the radar.

David gravatar imageDavid ( 2015-02-25 09:47:35 +0100 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2016-02-20 14:58:58 +0100

Paddy Landau gravatar image

updated 2016-02-24 21:52:33 +0100

This is a perennial problem, caused by Mark Shuttleworth's insane decision to hard-code which legacy icons are allowed.

You can overcome this limitation with the "Indicator Systemtray Unity" app, which allows all legacy systray icons to work. To use, open a terminal and enter these commands:

sudo apt-add-repository ppa:fixnix/indicator-systemtray-unity
sudo apt update
sudo apt install indicator-systemtray-unity

Log out and in again (or reboot).

More information in this answer by GGleb.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2014-06-17 19:49:50 +0100

Seen: 853 times

Last updated: Feb 24 '16