Quickstarter icon doesn't show under Unity

I am running Ubuntu 14.04 x64, have Quickstarter enabled and it seems working, only problem is the indicator icon for it is missing from the system tray.

Me too, but I never bothered to check it out. (Unity … not my favourite bit of Ubuntu!) There could be a related bug reported for KDE/Kubuntu (fdo#72243) - does the work-around suggested in Comment 1 help? (I can’t check just now.)

It doesn’t work with both libreoffice-gnome and libreoffice-gtk being installed.

Removing libreoffice-gnome or libreoffice-gtk would not be good idea - then also part of LibreOffice functionality will be removed. Also there are some dependencies. Under LXDE this quickstarter icon is working and both of the mentioned packages are installed. Besides - also under Unity 2D the quickstart icon does not appear. But still soffice.bin and oosplash processes appears to be working. I compared here Ubuntu and Lubuntu 14.04 with all updates at current day.

After @EdmundLaugasson’s helpful comment, I looked at the bug reports again, and saw his addition to fdo#77936 “When enable QuickStarter in Ubuntu Unity, there is no systray in the notification area”, and it is still a problem in (Ubuntu 14.04 LTS, x64). Good to keep this on the radar.

This is a perennial problem, caused by Mark Shuttleworth’s insane decision to hard-code which legacy icons are allowed.

You can overcome this limitation with the “Indicator Systemtray Unity” app, which allows all legacy systray icons to work. To use, open a terminal and enter these commands:

sudo apt-add-repository ppa:fixnix/indicator-systemtray-unity
sudo apt update
sudo apt install indicator-systemtray-unity

Log out and in again (or reboot).

More information in this answer by GGleb.