Ask Your Question
0

Unable to disable file locking (WebDav FS) [closed]

asked 2014-07-01 11:12:23 +0200

jorge27 gravatar image

updated 2015-08-30 19:51:42 +0200

Alex Kemp gravatar image

Hello all,

Im running Ubuntu 13:10 with Lo 4.1.3 or 4.2.5 .

I know this topic has been already commented, but it doesnt work on any version from 4.1.* to 4.2.* that I have tried..

http://ask.libreoffice.org/en/questio...

http://wavesco.com/libreoffice-openof...

I want to disable file locking in LO, get rid of the annoying ".~lock.XXXXXX" when working inside a DavFs FS.

Changing the line in the soffice script "export SAL_ENABLE_FILE_LOCKING" doesnt work. Im running out of ideas...I have tested this solution, which is proposed in many places as the correct one, but is not working for me.

Thanks in advance,

Jorge.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-02 12:20:08.798624

1 Answer

Sort by » oldest newest most voted
0

answered 2014-07-02 14:26:59 +0200

oweng gravatar image

updated 2014-08-18 16:34:30 +0200

Does the answer here relating to GVFS issues help as a workaround? According to bug fdo#39529, locking has never been implemented for WebDAV and yet it appears there was a problem with LO not releasing lock files over WebDAV (fdo#72157) which has been fixed for v4.2.6 and v4.3. I am a bit confused at this, so have commented in the former bug for some clarity on the situation.

EDIT: It appears the fix for fdo#72157 was only partial. Bug fdo#82744 indicates that File > Save still mistakenly releases the lock on the file.

With regard to turning off file locking I presume the environment variable (SAL_ENABLE_FILE_LOCKING) was commented out (as suggested in the README) rather than set to a value? This seems the only method of turning off locking that I can find.

edit flag offensive delete link more

Comments

Dont think so, the problem is that ".locks.*" are still appearing on the davfs FS even when I have disabled them. It is a problem of LO, that doesnt disable lock although I have followed the instructions to do so:

http://ask.libreoffice.org/en/questio...

It might be a bug..

jorge27 gravatar imagejorge27 ( 2014-07-07 12:36:15 +0200 )edit

@jorge27, I have updated my answer (nothing much to offer though). I can bug reports for lock files not being created, but none for the environment variable not working as expected. Generally users want the files locked. What type of WebDAV access are you using e.g., Alfresco CMIS?

oweng gravatar imageoweng ( 2014-07-08 12:32:55 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2014-07-01 11:12:23 +0200

Seen: 1,168 times

Last updated: Aug 18 '14