Ask Your Question

Read only content cannot be changed, no modifications will be accepted

asked 2014-08-06 10:59:22 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have tried going into Options, Writer, Formating Aids and unticking Cursor in Protected Areas.

I have seen so many posts about this but never see a successful solution. Its a very comment problem. Please can this get solved. I want to recommend that my customers change to LibreOffice but how can I when a problem as big as this exsists.

I am using, On Windows 8.1

edit retag flag offensive close merge delete


@"Nick Halliwell": You posted a question and updated it stressing it's urgency. There were three answers meanwhile. Would you be so kind to tell us which answer met (part of) your question - or in which way the contributors may have misunderstood it? It should also be helpful to get linked here some of the "many posts about this". you have seen to better understand the problem.

Lupp gravatar imageLupp ( 2014-08-20 20:07:04 +0200 )edit

Lupp, the title of the post "Read only content cannot be changed. No modifications will be accepted." is the exact text of the error dialog. It has nothing to do with write-protected files, email attachments stored in /tmp, and the only "solution" out there is to delete the "protected" text. It is a known bug since 2011

and the correct answer to this post is "this is a known bug since 2011 and it is still marked as "NEW".

I have the same issue.

jerquee gravatar imagejerquee ( 2014-10-16 23:05:51 +0200 )edit

I never had experienced that specific problem - and therefore had another notion of the subject's meaning. The topic in libreofficeforum you linked in is containing one link to a bug report from 2013-06-19. It also contains an attached example which is showing for me the "fieldmark highlighting" contributors tak about but the text contained is editable for me with Writer V4.3.2 under Win 8.1 (alas!). Nonetheless we have clearly a (complicated?) bug.

Lupp gravatar imageLupp ( 2014-10-16 23:55:53 +0200 )edit

"... It has nothing to do with write-protected files, ... " It might have to do with the history of the document and its former states as a file stored and loaded by whatever software with whatever filters in whatever formats.


Just inspected the content.xml out of the above mentioned example. The problematic fields were fragmented in a ridiculous way. Don't think that can be the result of a curriculum vitae under the rule of odf.

Lupp gravatar imageLupp ( 2014-10-17 00:18:51 +0200 )edit
cement_head gravatar imagecement_head ( 2016-02-24 20:04:58 +0200 )edit

Got here because of also getting the "Write-protected content cannot be changed." message and searching for answers. In my case saved original document as *.doc (97-2003), lost some Form Controls (Radio Buttons, List Box) in the process. Later Saved As *.odt to fix document and re-do the Controls. Check Boxes changed to grey, could not delete them, got above message. Read this post, selected one character before and one after Check Box, then deleted it successfuly! Thanks for the help.

Petr_Libre gravatar imagePetr_Libre ( 2016-06-23 20:51:04 +0200 )edit

15 Answers

Sort by » oldest newest most voted

answered 2014-08-20 12:54:05 +0200

Have you tried 'Format' > 'Sections' ? Then select the Section (eg. Section1) with 'Write Protection' activated and deactivate it. Now it should be editable...

edit flag offensive delete link more


BEST answer! Thank you. Tends to happen when one converts old documents (esp if from a different technology e.g. MS Word.

elmarr gravatar imageelmarr ( 2015-08-11 13:21:02 +0200 )edit

In my case, the sections entry in the format menu is grayed out.

flavio gravatar imageflavio ( 2015-09-25 13:40:43 +0200 )edit

This worked for me. Pasting a DDE link is really frustrating to fix. Thanks for your help!

SolarDesalination gravatar imageSolarDesalination ( 2017-05-29 19:02:27 +0200 )edit

just ran in to the same problem and this worked, thanks.

puchu gravatar imagepuchu ( 2017-06-10 18:37:30 +0200 )edit

Format > Sections is greyed out in my case. What worked for me is this solution: uncheck the following option Tools / Options / LibreOffice Writer / Compatibility / Protect form

bartovan gravatar imagebartovan ( 2018-08-12 12:44:17 +0200 )edit

answered 2018-05-26 02:57:30 +0200

Miguel Moreno gravatar image

updated 2018-05-26 03:00:35 +0200

I also got this problem after importing a Word ".doc" file with some embedded form objects ( check boxes ).

The file opens up just fine in Word, where I can check and uncheck the check boxes and edit the content with no problem.

But after importing and loading it into LibreWriter, the status bar showed "read only" and when trying to edit the contents a message popped up saying "Write-protected content cannot be changed, no modifications will be accepted". Check boxes could still be checked / unchecked, though.

The solution involving sections ( "Format" -> "Sections" ) didn't work, because it was grayed out ( --> no sections ).

Finally, the solution that worked for me was the one about "protected form":

  • Go to "Tools" -> "Options" -> "LibreOffice Writer" -> "Compatibility" -> "Protect form"
  • Make sure the "Protect form" option is unchecked.

Now you can check / uncheck the check boxes and edit / modify the contents of the document.

( Using LibreOffice and Ubuntu 16.04 LTS )

edit flag offensive delete link more


Thank you - for me it was "Protect form" and "Cursor in Protected Areas"

sdaau gravatar imagesdaau ( 2018-12-27 16:37:08 +0200 )edit

answered 2015-03-13 15:36:07 +0200

marcinkowski gravatar image

I found an answer that worked for me here:

  1. Select at least one character prior to the field, all the field, and at least one character after the field.
  2. Cut this content.
  3. Paste it back as unformatted text.
  4. Manually remove the “#” before and after the re-pasted content.
  5. Manually reformat any character styles that were present in the original field i.e., bold, italic, etc.

The field is lost by doing this, but at least you have the content.

edit flag offensive delete link more


Got good hint from this answer.. Try repasting the contents in the starting field (or cell as in table). It worked for me. Weird problem, and solution even more weird, :-)

swathyprabhu gravatar imageswathyprabhu ( 2016-08-10 18:17:38 +0200 )edit

Thank you so much.

neriana gravatar imageneriana ( 2017-10-26 13:19:46 +0200 )edit

Did not work for me. What worked for me is this solution: uncheck the following option Tools / Options / LibreOffice Writer / Compatibility / Protect form

bartovan gravatar imagebartovan ( 2018-08-12 12:44:33 +0200 )edit

answered 2017-12-04 10:54:26 +0200

quazgar gravatar image

I solved my problem with protected forms by unsetting an option in the Options dialog:

Tools > Options ... > LibreOffice Writer > Compatibility > Remove the tick mark from the " Protect form " line.

edit flag offensive delete link more


THANK YOU! It really should be listed here:

trevize gravatar imagetrevize ( 2018-07-11 07:10:14 +0200 )edit

After half an hour of searching this is the answer for me!

dewd gravatar imagedewd ( 2020-02-24 17:20:12 +0200 )edit

answered 2016-08-09 18:25:55 +0200

Whatever333 gravatar image

updated 2016-08-09 21:41:56 +0200

I imported a DOC file whose content was protected. (And Insert -> Sections, Format -> Sections didn't work, because it was grayed out. Neither did saving without a password and/or in the ODT format.)

What worked was the following:

  • Under Tools -> Options -> LibreOffice Writer -> Formatting Aids -> Protected Area activate "Ignore protection".


  • That will also remove protection from Table of Contents, etc. (if it was created as protected)
  • One might want deactivate it again after editing, to prevent unintended edits in future
  • I think I had to restart LO on the first activation, but couldn't reproduce it later (doc becomes editable immediately) - your mileage may vary
edit flag offensive delete link more


Cannot upvote yet, but thank you nevertheless.

olafdietsche gravatar imageolafdietsche ( 2016-08-16 11:54:24 +0200 )edit

Thanks For mac option was named "Protect form" and it was under Tools -> Options -> LibreOffice Writer -> Compatibility

Kanape gravatar imageKanape ( 2017-05-03 10:41:24 +0200 )edit

@Kanape Thanks, it works for me on Linux too

eNca gravatar imageeNca ( 2018-01-28 15:49:50 +0200 )edit

answered 2015-10-06 14:59:10 +0200

I imported a form from an RTF file, which included a table, which had some part of its cells somehow protected. Saving this as .odt file did not help.

What did help is the following:

  • Save to a different format (e. g. MS Word 97/2000/XP/2003 (.doc)), that eventually does not support this protection.
  • Close LibreOffice Writer.
  • Open the new file (e. g. the .doc file) with LibreOffice Writer and test if the removal of the protection has been successful.
  • Save back to a .odt file.
edit flag offensive delete link more

answered 2014-08-06 11:38:34 +0200

Lupp gravatar image

updated 2014-10-20 12:40:48 +0200

What else should 'Read Only' mean? One must have applied the setting and should have known what he (f/m) does.

If needs arise to cancel protection: There are different containers of text that can be protected (tables by every singel cell; frames - just to name two examples). Thus a refined design of using protection in a document / template is possible. A global switching off of protections will not be available.

I think the documents should be analised with the help of the navigator to identify the containers concerned - and, of course, the templates should be reworked to get documents as intended.

Editing: In a comment above "jerquee" linked in a thread from another forum on LibreOffice. There "jonhayes" had attached an example file to his post. Having studied that a bit with the help of an XML-editor I think the most likely cause of the problem is carelessly pasting content copied from non-odf source and containing incompatible or unsufficiently specified field-types. For better understanding you may refer to "owengs"'s contributions to this thread. The bug in LibreOffice should be to not refuse accepting pasted contents that cannot be thoroughly validated for one or another reason. We experience just another aspect of the "compatibility dilemma" enjoyed to the full by an unfortunately powerful competitor.

edit flag offensive delete link more

answered 2016-08-11 14:01:27 +0200

This is what worked for me (tried the "clip from one char before..." suggestion above but that just refused me as well) :-

  1. Re-SAVE the document from Libreoffice in the "OPENOFFICE DOCX" format (the one right down at the bottom of the format selector - NOT Windows DOCX) ;

  2. The close and Open the resulting document anew: the locked section is now unlocked.

Small disruption to some centring but nothing problematic.

Good luck all

edit flag offensive delete link more

answered 2016-10-22 02:12:23 +0200

I see that this has been a problem for some time. I have a document that was created in MS Office. It has a table in it. A very simple table. I can open the document in MS Office and fill in the table. I can open the document in OpenOffice and fill in the table. When I open the document in LibreOffice, it claims that the cells cannot be written into and there is no way to change that. I have tried everything I have read here and elsewhere. LibreOffice is treating the table incorrectly and, as a result, this form and others like it cannot be used in LibreOffice. If anybody has a way to fix this (and I am starting to doubt that there is a fix given the back-and-forthing) I would appreciate having somebody tell me what it is. And I will tell you up front that the solutions which center on unprotecting the cells do not work because apparently LibreOffice, while it says the cells cannot be written into, does not have an option to kill the protection. In fact, there is no option presented no matter how much I right click.

edit flag offensive delete link more

answered 2018-01-23 18:59:13 +0200

updated 2018-01-23 18:59:49 +0200

Got this error message in LO in Ubuntu 17.04. In my case, it also said "read only" in the status bar at the bottom of the screen.

Solution: uncheck the following option Tools / Options / LibreOffice Writer / Compatibility / Protect form

All other solutions failed for me.

edit flag offensive delete link more


I had the same error in a document converted from Word. This was the only solution that worked for me too.

bartovan gravatar imagebartovan ( 2018-08-12 12:41:20 +0200 )edit
Login/Signup to Answer

Question Tools



Asked: 2014-08-06 10:59:22 +0200

Seen: 57,862 times

Last updated: Dec 20 '19