Read only content cannot be changed, no modifications will be accepted

I have tried going into Options, Writer, Formating Aids and unticking Cursor in Protected Areas.

I have seen so many posts about this but never see a successful solution. Its a very comment problem. Please can this get solved. I want to recommend that my customers change to LibreOffice but how can I when a problem as big as this exsists.

I am using, On Windows 8.1

@“Nick Halliwell”: You posted a question and updated it stressing it’s urgency. There were three answers meanwhile. Would you be so kind to tell us which answer met (part of) your question - or in which way the contributors may have misunderstood it? It should also be helpful to get linked here some of the “many posts about this”. you have seen to better understand the problem.

Lupp, the title of the post “Read only content cannot be changed. No modifications will be accepted.” is the exact text of the error dialog. It has nothing to do with write-protected files, email attachments stored in /tmp, and the only “solution” out there is to delete the “protected” text. It is a known bug since 2011

and the correct answer to this post is "this is a known bug since 2011 and it is still marked as “NEW”.

I have the same issue.

I never had experienced that specific problem - and therefore had another notion of the subject’s meaning. The topic in libreofficeforum you linked in is containing one link to a bug report from 2013-06-19. It also contains an attached example which is showing for me the “fieldmark highlighting” contributors tak about but the text contained is editable for me with Writer V4.3.2 under Win 8.1 (alas!). Nonetheless we have clearly a (complicated?) bug.

"… It has nothing to do with write-protected files, … " It might have to do with the history of the document and its former states as a file stored and loaded by whatever software with whatever filters in whatever formats.

Just inspected the content.xml out of the above mentioned example. The problematic fields were fragmented in a ridiculous way. Don’t think that can be the result of a curriculum vitae under the rule of odf.

Got here because of also getting the “Write-protected content cannot be changed.” message and searching for answers. In my case saved original document as *.doc (97-2003), lost some Form Controls (Radio Buttons, List Box) in the process. Later Saved As *.odt to fix document and re-do the Controls. Check Boxes changed to grey, could not delete them, got above message. Read this post, selected one character before and one after Check Box, then deleted it successfuly! Thanks for the help.

Have you tried ‘Format’ > ‘Sections’ ?
Then select the Section (eg. Section1) with ‘Write Protection’ activated and deactivate it.
Now it should be editable…

BEST answer! Thank you. Tends to happen when one converts old documents (esp if from a different technology e.g. MS Word.

In my case, the sections entry in the format menu is grayed out.

just ran in to the same problem and this worked, thanks.

Format > Sections is greyed out in my case. What worked for me is this solution: uncheck the following option Tools / Options / LibreOffice Writer / Compatibility / Protect form

This is the best answer it works for me thanks "Format > Section > uncheck protect on Write Protection and OK.

2020, LibreOffice and bug still exists. and this was the solution I was looking for.

I found a solution for this problem. This happened to a particular cell while I was editing a table. I could get rid of it changing the size of the cell. I grabbed the top edge of the cell and dragged it down, and then I could edit it again. I don’t know if it will work for you, but it did for me. Nothing else did work, except for changing the size of the cell.

I found an answer that worked for me here:

  1. Select at least one character prior to the field, all the field, and
    at least one character after the
  2. Cut this content.
  3. Paste it back as unformatted text.
  4. Manually remove the “#” before and after the re-pasted content.
  5. Manually reformat any character styles that were present in the
    original field i.e., bold, italic,

The field is lost by doing this, but
at least you have the content.

Got good hint from this answer…
Try repasting the contents in the starting field (or cell as in table). It worked for me.
Weird problem, and solution even more weird, :slight_smile:

Thank you so much.

Did not work for me. What worked for me is this solution: uncheck the following option Tools / Options / LibreOffice Writer / Compatibility / Protect form

I solved my problem with protected forms by unsetting an option in the Options dialog:

Tools > Options … > LibreOffice Writer > Compatibility > Remove the tick mark from the " Protect form " line.

1 Like