Ask Your Question
3

Read only content cannot be changed, no modifications will be accepted

asked 2014-08-06 10:59:22 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have tried going into Options, Writer, Formating Aids and unticking Cursor in Protected Areas.

I have seen so many posts about this but never see a successful solution. Its a very comment problem. Please can this get solved. I want to recommend that my customers change to LibreOffice but how can I when a problem as big as this exsists.

I am using 4.3.0.4, On Windows 8.1

edit retag flag offensive close merge delete

Comments

@"Nick Halliwell": You posted a question and updated it stressing it's urgency. There were three answers meanwhile. Would you be so kind to tell us which answer met (part of) your question - or in which way the contributors may have misunderstood it? It should also be helpful to get linked here some of the "many posts about this". you have seen to better understand the problem.

Lupp gravatar imageLupp ( 2014-08-20 20:07:04 +0100 )edit

Lupp, the title of the post "Read only content cannot be changed. No modifications will be accepted." is the exact text of the error dialog. It has nothing to do with write-protected files, email attachments stored in /tmp, and the only "solution" out there is to delete the "protected" text. It is a known bug since 2011

http://en.libreofficeforum.org/node/7289

and the correct answer to this post is "this is a known bug since 2011 and it is still marked as "NEW".

I have the same issue.

jerquee gravatar imagejerquee ( 2014-10-16 23:05:51 +0100 )edit

I never had experienced that specific problem - and therefore had another notion of the subject's meaning. The topic in libreofficeforum you linked in is containing one link to a bug report from 2013-06-19. It also contains an attached example which is showing for me the "fieldmark highlighting" contributors tak about but the text contained is editable for me with Writer V4.3.2 under Win 8.1 (alas!). Nonetheless we have clearly a (complicated?) bug.

Lupp gravatar imageLupp ( 2014-10-16 23:55:53 +0100 )edit

"... It has nothing to do with write-protected files, ... " It might have to do with the history of the document and its former states as a file stored and loaded by whatever software with whatever filters in whatever formats.

....

Just inspected the content.xml out of the above mentioned example. The problematic fields were fragmented in a ridiculous way. Don't think that can be the result of a curriculum vitae under the rule of odf.

Lupp gravatar imageLupp ( 2014-10-17 00:18:51 +0100 )edit
cement_head gravatar imagecement_head ( 2016-02-24 20:04:58 +0100 )edit

Got here because of also getting the "Write-protected content cannot be changed." message and searching for answers. In my case saved original document as *.doc (97-2003), lost some Form Controls (Radio Buttons, List Box) in the process. Later Saved As *.odt to fix document and re-do the Controls. Check Boxes changed to grey, could not delete them, got above message. Read this post, selected one character before and one after Check Box, then deleted it successfuly! Thanks for the help.

Petr_Libre gravatar imagePetr_Libre ( 2016-06-23 20:51:04 +0100 )edit

15 Answers

Sort by » oldest newest most voted
0

answered 2015-10-06 14:59:10 +0100

I imported a form from an RTF file, which included a table, which had some part of its cells somehow protected. Saving this as .odt file did not help.

What did help is the following:

  • Save to a different format (e. g. MS Word 97/2000/XP/2003 (.doc)), that eventually does not support this protection.
  • Close LibreOffice Writer.
  • Open the new file (e. g. the .doc file) with LibreOffice Writer and test if the removal of the protection has been successful.
  • Save back to a .odt file.
edit flag offensive delete link more
1

answered 2015-03-13 15:36:07 +0100

marcinkowski gravatar image

I found an answer that worked for me here:

  1. Select at least one character prior to the field, all the field, and at least one character after the field.
  2. Cut this content.
  3. Paste it back as unformatted text.
  4. Manually remove the “#” before and after the re-pasted content.
  5. Manually reformat any character styles that were present in the original field i.e., bold, italic, etc.

The field is lost by doing this, but at least you have the content.

edit flag offensive delete link more

Comments

Got good hint from this answer.. Try repasting the contents in the starting field (or cell as in table). It worked for me. Weird problem, and solution even more weird, :-)

swathyprabhu gravatar imageswathyprabhu ( 2016-08-10 18:17:38 +0100 )edit

Thank you so much.

neriana gravatar imageneriana ( 2017-10-26 13:19:46 +0100 )edit

Did not work for me. What worked for me is this solution: uncheck the following option Tools / Options / LibreOffice Writer / Compatibility / Protect form

bartovan gravatar imagebartovan ( 2018-08-12 12:44:33 +0100 )edit
3

answered 2014-08-20 12:54:05 +0100

Have you tried 'Format' > 'Sections' ? Then select the Section (eg. Section1) with 'Write Protection' activated and deactivate it. Now it should be editable...

edit flag offensive delete link more

Comments

BEST answer! Thank you. Tends to happen when one converts old documents (esp if from a different technology e.g. MS Word.

elmarr gravatar imageelmarr ( 2015-08-11 13:21:02 +0100 )edit

In my case, the sections entry in the format menu is grayed out.

flavio gravatar imageflavio ( 2015-09-25 13:40:43 +0100 )edit

This worked for me. Pasting a DDE link is really frustrating to fix. Thanks for your help!

SolarDesalination gravatar imageSolarDesalination ( 2017-05-29 19:02:27 +0100 )edit

just ran in to the same problem and this worked, thanks.

puchu gravatar imagepuchu ( 2017-06-10 18:37:30 +0100 )edit
2

Format > Sections is greyed out in my case. What worked for me is this solution: uncheck the following option Tools / Options / LibreOffice Writer / Compatibility / Protect form

bartovan gravatar imagebartovan ( 2018-08-12 12:44:17 +0100 )edit
0

answered 2014-08-06 11:40:29 +0100

Pedro gravatar image

If the document is set as Read Only that is probably because you opened it directly from an email attachment (and therefore it is stored in a Temporary folder, where you don't want it to be). The proper way to edit a document is to Save the attached file to some organized folder you own and then Open the document for Editing.

Another important reminder: NEVER get an x.x.0 version. It will (most probably) have bugs and regressions. You should get the version with the highest 3rd digit (currently 4.2.6)

Example: in the Download page (at the very bottom) you will see

LibreOffice is available in the following released version

4.1.6
4.2.5
4.2.6
4.3.0

You should get either version 4.2.6 or 4.1.6 (older, with less features which you might or not need, but equally bug free)

Recommending any other version to your customers is doing a bad service to them, to the project and especially to yourself (because, as usual, if you recommend anything, any problem in the software is your fault and people expect YOU to fix it :) )

edit flag offensive delete link more
0

answered 2014-08-06 11:38:34 +0100

Lupp gravatar image

updated 2014-10-20 12:40:48 +0100

What else should 'Read Only' mean? One must have applied the setting and should have known what he (f/m) does.

If needs arise to cancel protection: There are different containers of text that can be protected (tables by every singel cell; frames - just to name two examples). Thus a refined design of using protection in a document / template is possible. A global switching off of protections will not be available.

I think the documents should be analised with the help of the navigator to identify the containers concerned - and, of course, the templates should be reworked to get documents as intended.

Editing: In a comment above "jerquee" linked in a thread from another forum on LibreOffice. There "jonhayes" had attached an example file to his post. Having studied that a bit with the help of an XML-editor I think the most likely cause of the problem is carelessly pasting content copied from non-odf source and containing incompatible or unsufficiently specified field-types. For better understanding you may refer to "owengs"'s contributions to this thread. The bug in LibreOffice should be to not refuse accepting pasted contents that cannot be thoroughly validated for one or another reason. We experience just another aspect of the "compatibility dilemma" enjoyed to the full by an unfortunately powerful competitor.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

4 followers

Stats

Asked: 2014-08-06 10:59:22 +0100

Seen: 55,672 times

Last updated: Dec 20 '19