Ask Your Question
1

PDF Forms created with libreoffice will not display correctly in Adobe Reader [closed]

asked 2012-07-18 15:54:38 +0200

aeronaut gravatar image

hello everyone. i have a strange problem: i want to create a pdf form with libreoffice. the problem i will describe only occurs in adobe reader, not in other pdf readers such as foxit, apple preview or evince. the forms are pretty small (0.5 cm high with times new roman, 9pt). in adope reader, what you type into the fields is not centered as in the others, but only half of the letters are viewable, it is cut in half. it seems that it is conversed to times new roman postscript, and if i change it with adobe products to normal times new roman, the problem will no longer occur. i dont know if that is a part of the solution. since i want my coworkers to be able to work on the form with libreoffice, i would prefer a solution with libreoffice. does anyone have an idea what might be the problem?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-10-25 01:12:14.424965

Comments

Only a guess - among the "Export as PDF" options, there's "Embed standard fonts". Does it help activating this option?

tohuwawohu gravatar imagetohuwawohu ( 2012-07-18 17:31:32 +0200 )edit

no - sorry, i have already tried it, but it did not work. unfortunately, i cannot - for sake of "it should fit to one page" - make the fields bigger.

aeronaut gravatar imageaeronaut ( 2012-07-18 19:06:20 +0200 )edit

I have the same problem in OSX 10.9.2 with Libre Office 4.1.5.3. The problem is also that the file doesn't get that Adobe icon in Finder and elsewhere.

Peite gravatar imagePeite ( 2014-04-08 14:39:13 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2012-07-19 11:44:14 +0200

tohuwawohu gravatar image

updated 2012-07-31 16:35:16 +0200

There seem to be some issues with multi-line "plain" text boxes. If your text box shouldn't support multi-line input, try to set the "Text Type" property to "Single Line". Alternatively, it may help to replace the standard text box by a "Formatted Field".

EDIT:

The button to insert a "formatted Field" (with german l10n: "Formatiertes Feld") is next to the "Text Box" ("Textfeld") button. In the following screenshot, it's the third button in the second row.

image description

edit flag offensive delete link more

Comments

Thank you very much, and I am sorry that i could not read your answer for 10 days. The single line does not help, and I can't figure out what formatted field might mean in my german libreoffice version, do you have an idea?

aeronaut gravatar imageaeronaut ( 2012-07-31 15:30:25 +0200 )edit

@aeronaut: I've added a screenshot.

tohuwawohu gravatar imagetohuwawohu ( 2012-07-31 16:36:19 +0200 )edit
0

answered 2013-02-28 17:18:16 +0200

qubit gravatar image

Hi @aeronaut,

If installing the latest release doesn't seem to fix this problem, please file a bug and provide a list of steps that can reproduce your problem. The QA team will be happy to help you track down this issue!

Please post a link to any bugs you file in a comment below using the format "fdo#123456".

Thanks!

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-07-18 15:54:38 +0200

Seen: 3,721 times

Last updated: Feb 28 '13