Ask Your Question
1

How to disable auto date format when opening a file [closed]

asked 2012-07-21 00:51:51 +0200

henry gravatar image

updated 2015-10-26 22:18:34 +0200

Alex Kemp gravatar image

When I open the file I need to work on, LO Calc 3.3.4 automatically interprets some cells as date and changes their values. For example the cell content '4-6' gets converted to '06-Apr'. If I then change its format to text it becomes '41005'. I tried different options, Expand Formatting,language separator, etc without any luck. I can't put a ' in front of the content because by the time I can edit the file is already changed. How can I get LO to respect the value '4-6' as is?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-10-26 22:18:48.748279

Comments

File is xlsx

henry gravatar imagehenry ( 2012-07-21 02:57:45 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2013-03-13 10:30:47 +0200

qubit gravatar image

Hi @henry,

Still looking for an answer here?

You mentioned using LO 3.3.4. We've now released LO 4.0 -- could you try with the latest release and let us know if you're still experiencing the same problems?

Thanks!

edit flag offensive delete link more
0

answered 2013-03-14 00:14:19 +0200

Mark12547 gravatar image

A trick I have used in Excel and I suspect would also work in Calc is to select the cell (or, in my case, highlight the whole column by clicking on the column heading), and then going into "Format" -> "Format Cells" (or Ctl+1 which is CTL + the digit 1), scrolling down the "Category" column, and clicking on text. That way, what is entered in that cell is interpreted as text, not as a date, not as a number, but as text.

Of course, this requires that the file would then subsequently be saved with the cell formatted as a category of "Text".

If this doesn't help, please explain in more detail what you are doing. Are you opening a non-LibreOffice file and allowing it to convert, or opening a .CSV file (and does it include quotes around the text of text columns?), or are you doing something else?

edit flag offensive delete link more
0

answered 2012-07-21 01:48:43 +0200

m.a.riosv gravatar image

What kind of file are you opening?. It is a native .ods file?

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-07-21 00:51:51 +0200

Seen: 775 times

Last updated: Mar 14 '13