Ask Your Question
2

Change default printer language type to PostScript (Level from driver) [closed]

asked 2012-02-23 18:19:05 +0100

anonymous user

Anonymous

updated 2015-11-15 07:37:27 +0100

Alex Kemp gravatar image

LibreOffice (Linux - Kubuntu 11.10) defaults the Printer Language type to PDF. I want to use PostScript (Level from Driver), but I can find no way to set this for LibreOffice - I have to choose this option each time I print. CUPS or the pinter settings will not allow me to change the default, and this is a problem ONLY for LibreOffice. PDF print for some reason always prints double sided even if I try to choose another option, but it prints correctly using PostScript.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-11-15 07:37:51.774651

Comments

My configuration is Fedora with multiple desktop (KDE, Mate, xfce) and LibreOffice behaves the same, therefore it is not a matter of distribution but a pure LO issue. The big annoyance is my printer (rather old but with a very fine resolution) does not understand PDF and rejects silently the file sent on the LAN. When I (myself not the printer) time-out, I remember this @#!$ default setting and must resend the print with the correct language.

ajlittoz gravatar imageajlittoz ( 2013-09-01 17:19:15 +0100 )edit

8 Answers

Sort by » oldest newest most voted
2

answered 2012-04-14 16:28:19 +0100

Bernhard Reiter gravatar image

You can use LibreOffice's /usr/lib/libreoffice/program/spadmin tool to permanently change the default Printer Language for your printer(s).

edit flag offensive delete link more
2

answered 2013-11-30 19:37:42 +0100

Laszlo gravatar image

updated 2013-11-30 19:46:22 +0100

Close every document opened by LibreOffice. Go to LibreOffice main application (not writer or calc, etc.), Tools menu, Options menu, LibreOffice node in treeview, Print node, then change the "PDF as Standard Print Job Format" (un-check the box), then OK. It will restart LibreOffice, then it will keep whatever you set in LibreOffice (writer or calc), File, Printer Settings, Properties, Device tab, Printer Language type. This worked for me with LibreOffice 4.1.2.3 on Linux Mint 16. 2013/11/30

edit flag offensive delete link more
1

answered 2012-05-13 19:08:27 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

1 go to libre office 2 go to file 3 go to printer setttings 4 go to properties 5 go to device 6 below the major part of this windows you will see "printer language support" 7 change it to whatever you want 8 done!! tell me if this helps

edit flag offensive delete link more

Comments

This does not set the default.

artfulrobot gravatar imageartfulrobot ( 2015-05-19 12:04:38 +0100 )edit
0

answered 2013-01-15 09:26:31 +0100

For me, spadmin doesn't change the setting, neither does changing the printer settings from within LibreOffice. It always falls back to pdf, which causes a quite annoying bug: all landscape is kept as it is on screen and printed on portrait, thus cutting off part of the contents.

edit flag offensive delete link more
0

answered 2013-09-01 16:04:49 +0100

andy gravatar image

+1 for this question.

edit flag offensive delete link more
0

answered 2012-10-04 14:11:53 +0100

ñull gravatar image

In Opensuse the location of the Printer settings tool is /usr/lib64/libreoffice/program/spadmin for 64 bit systems. Worked for me to change the setting there.

edit flag offensive delete link more
-1

answered 2012-03-28 22:58:18 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

+1 for this question

edit flag offensive delete link more
-1

answered 2012-03-01 13:10:10 +0100

Fintan gravatar image

I am having the same issue. anyone with an idea?

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2012-02-23 18:19:05 +0100

Seen: 7,508 times

Last updated: Nov 30 '13