Change default printer language type to PostScript (Level from driver)

LibreOffice (Linux - Kubuntu 11.10) defaults the Printer Language type to PDF. I want to use PostScript (Level from Driver), but I can find no way to set this for LibreOffice - I have to choose this option each time I print. CUPS or the pinter settings will not allow me to change the default, and this is a problem ONLY for LibreOffice. PDF print for some reason always prints double sided even if I try to choose another option, but it prints correctly using PostScript.

My configuration is Fedora with multiple desktop (KDE, Mate, xfce) and LibreOffice behaves the same, therefore it is not a matter of distribution but a pure LO issue. The big annoyance is my printer (rather old but with a very fine resolution) does not understand PDF and rejects silently the file sent on the LAN. When I (myself not the printer) time-out, I remember this @#!$ default setting and must resend the print with the correct language.

You can use LibreOffice’s /usr/lib/libreoffice/program/spadmin tool to permanently change the default Printer Language for your printer(s).

Close every document opened by LibreOffice. Go to LibreOffice main application (not writer or calc, etc.), Tools menu, Options menu, LibreOffice node in treeview, Print node, then change the “PDF as Standard Print Job Format” (un-check the box), then OK. It will restart LibreOffice, then it will keep whatever you set in LibreOffice (writer or calc), File, Printer Settings, Properties, Device tab, Printer Language type. This worked for me with LibreOffice on Linux Mint 16. 2013/11/30

1 go to libre office
2 go to file
3 go to printer setttings
4 go to properties
5 go to device
6 below the major part of this windows you will see “printer language support”
7 change it to whatever you want
8 done!!
tell me if this helps

This does not set the default.

I am having the same issue. anyone with an idea?

+1 for this question

In Opensuse the location of the Printer settings tool is /usr/lib64/libreoffice/program/spadmin for 64 bit systems. Worked for me to change the setting there.

For me, spadmin doesn’t change the setting, neither does changing the printer settings from within LibreOffice. It always falls back to pdf, which causes a quite annoying bug: all landscape is kept as it is on screen and printed on portrait, thus cutting off part of the contents.

+1 for this question.