Ask Your Question
0

Base won't run: errorrequires a Java runtime environment (JRE) to perform this task, java is already installed.

asked 2015-02-13 05:56:12 +0200

pltaSupport gravatar image

This is LibreOffice version 4.4 which I just installed. The Java is version jre8.1.0_31 (also just installed) running on Windows 7 Home Premium 64 bit system. When I open Base it allows creation of a new database but I can not create tables or anything else to put in it.

The entire content of the error message is: LibreOffice requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - LibreOffice - Advanced.

This is followed by a second message: The connection to the data source "New Database" could not be established. No Java installation could be found. Please check your installation.

What is wrong?

edit retag flag offensive close merge delete

7 Answers

Sort by » oldest newest most voted
1

answered 2015-02-13 18:22:25 +0200

horst gravatar image

You need to install the 32-bit Java. LO is a 32-bit program on Windows even if your Windows is a 64-bit version.

edit flag offensive delete link more

Comments

You are correct. I had the same problem. I had 64bit JRE installed. LO is a 32 bit program and requires 32 bit JRE. Also, if you are not very tech-savvy, it is advisable not to change the destination folder of the JRE during installation process.

iloovatar gravatar imageiloovatar ( 2015-09-22 08:39:01 +0200 )edit
1

answered 2015-02-13 18:20:08 +0200

pierre-yves samyn gravatar image

Hi - Install the JRE is not enough. Check that the radio button is selected. In the screenshot below it is not.

JRE Options

Other possibilities: you have not installed the 32-bit version of the JRE (to do even if you're on Windows 64) or defective jre (download problem).

edit flag offensive delete link more
0

answered 2016-12-12 06:47:39 +0200

Sorry, but having just figured it out- the answer is simple. People writing Open Office code are Developers. Therefore they (of course) use JDK (emphasize the big 'D') on their machines and not JRE. Install JDK (free and easily downloaded from Oracle) and it works just fine (you still have to go into the Preferences/Advance and 'Add' and select the file which will finally be visible, restart LibreOffice and then it does work).

One should maybe ask OO folks to check into this for the next update, or at least change the error message to reflect JDK and not JRE. I'm not a developer - just a user, so this might not be the place to add this, but I'm not sure where is. Apologies if it should be elsewhere.

edit flag offensive delete link more

Comments

JDK is a LOT larger download and uses more resources. JRE (and openjre) is fine for the majority. The JDk issue stems from a problem with Apple/Oracle.

Ratslinger gravatar imageRatslinger ( 2016-12-12 07:04:45 +0200 )edit
0

answered 2016-08-25 22:55:34 +0200

k9gardner gravatar image

This question is the closest I can come to my problem, which is what brings me here today, but I'm running LO on a Mac, running Yosemite. I know there are JRE issues with Yosemite, I've read the relevant support articles and believe that I've installed the JRE version that I need to use to make this work. But when I launch LO, I still get that same message that there's no run time environment. I've gone in to the Preferences / LibreOffice / Advanced and there's nothing listed in the box. Seems like there should be two, one of which might work and the other possibly not, but they're both installed and should be shown there, no? I thought about maybe pointing LO to them manually using the "Add" button, but I can't seem to find what I'm supposed to point it to. Anybody have sufficient knowledge of this platform to help find an answer? Or to point me in the direction of resources? It's just one stinkin' Base file that I'm trying to access for a particular project, which I guess I must've created before upgrading to Yosemite. Any help appreciated. Thanks.

edit flag offensive delete link more

Comments

You need JDK not JRE. see this post: click here. Also, you shouldn't bury a question as an answer within another question. Post it as a new question.

Ratslinger gravatar imageRatslinger ( 2016-08-25 23:07:30 +0200 )edit
0

answered 2016-12-28 18:39:21 +0200

I had the same problem. Resolved it by installing jdk 8 (not JRE) from http://www.oracle.com/technetwork/jav...

and then reinstall LO5.

edit flag offensive delete link more
0

answered 2015-09-03 17:15:50 +0200

Elie gravatar image

I have the same problem with version 5 64bits now. Win 7 64bit pro / latest JRE 64bits (8). Nothing helps.

edit flag offensive delete link more
0

answered 2015-02-13 18:36:28 +0200

updated 2015-02-13 18:38:13 +0200

1) Download and install 32-bit JRE (or JDK if you please) if you're using Opera, 32-bit Chrome/Chromium or Firefox. Otherwise skip it. Links on the bottom of this answer.

2) Download and install 64-bit JRE (or JDK if you please) if you're running 64-bit OS. Links on the bottom of this answer.

3) Make sure Java is enabled in LO's settings. LO is recommendable to be closed until Java is installed.

Use Java 8. If you -need- 7 (or even 6, bad idea), install the older 64-bit (if you're on 64-bit OS) first, otherwise 32-bit (don't install older 32-bit in addition of older 64-bit), then do as I said above.

JDK (recommended) : http://www.oracle.com/technetwork/jav... JRE : http://www.oracle.com/technetwork/jav...

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2015-02-13 05:56:12 +0200

Seen: 42,275 times

Last updated: Dec 28 '16