Message: "selected JRE is defective"

I am a new user, trying to use Base for the first time, and have tried this with LO versions 4.4.4 and 5.0.0, and a freshly installed Java (JRE), version 8.0.510 (64 bit), on a Windows 7 computer:

When I attempt to create a database, I get the message: “LibreOffice requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - LibreOffice - Advanced.”

I find a possible hint in Base won't run: error requires a Java runtime environment (JRE) to perform this task, java is already installed, in which one responder wrote, “You need to install the 32-bit Java. LO is a 32-bit program on Windows even if your Windows is a 64-bit version.” But someone else wrote, “1) Download and install 32-bit JRE (or JDK if you please) if you’re using Opera, 32-bit Chrome/Chromium or Firefox… 2) Download and install 64-bit JRE (or JDK if you please) if you’re running 64-bit OS.”

If current versions of LO really cannot work with 64-bit Java, and that problem cannot be fixed, then the installer should check the Java version and notify the user. But I hesitate to create an item in Bugzilla until I know whether this might be some unrelated problem with my system. And it seems strange that not very many people seem to have encountered this, given the fact (?) that most Windows computers these days use 64 bits.

Any suggestions will be appreciated. Thanks.

As I understand it, it is your system reporting to LO/OO that it is defective. Further, there is nothing to stop you having more than one JRE on the system, which should also allow you to choose between 32- & 64-bit. You can switch JRE on/off at:-

  • (menu):Tools|Options|LibreOffice|Advanced

If this helps then please tick the answer (:heavy_check_mark:).

Alex, thanks for your reply. I’ve now downloaded both 32- and 64-bit JRE and specifying the 32-bit version did indeed fix the problem. I’m not sure what you mean about my system reporting to LO that JRE is defective, and I’m perplexed that more people, apparently, haven’t encountered the problem or that it hasn’t been fixed. Requiring non-geeks to download a second JRE (with the same installed name as the first) and select it in Advanced options seems like a bug, so off to Bugzilla I go. Thanks.

“system reporting to LO that JRE is defective” : LO/OO has to interface with the system that it is on in order to work. With the JRE I would anticipate–this is an assumption, as I have NOT consulted the source code–that it contains within it’s API a function to say “properly installed & working YES” or “properly installed & working NO”, and that that is how LO/OO knows how it is functioning (or not).

Beginning with LO 5.0.0, release candidate 4, there is a 64-bit version. I have installed it and am using it 64-bit JRE without problems. Thanks.

@PeterChastain : You are aware of the fact that an RC of a new first digit version is expected to contain more than one errors? The version is still very fresh!

Thanks for the feedback, Peter - very useful for others in your situation to know.

I think this can’t be the solution:
Becse I am owner of 2 PC’s with 64 bit and the same LO Version (now and the same Win Home - and on one PC it works and on the other I get the message:
LibreOffice erfordert eine Java-Laufzeitumgebung (JRE), um diese Aufgabe auszuführen. Die ausgewählte JRE ist defekt. Bitte wählen Sie eine andere Version aus oder installieren Sie eine neue JRE und wählen Sie diese im Menü unter Extras - Optionen… - LibreOffice - Erweitert aus. (Translation: LibreOffice requires Java Runtime Environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it in the menu under Tools - Options … - LibreOffice - Advanced.) .

Java is found at: c:\program files\java\jre_1.8.0_60. As I remember correctly it worked on LO 4.xxxx.

Good to know that you know better than the OP, who fixed his problem using the solution provided at the time.

Did it ever occur to you that the answer was provided in July & now, 60 days later, the situation may have changed?

A 32-bit LO needs a 32-bit JRE, whilst a 64-bit LO needs a 64-bit JRE. At one time only 32-bit LO was provided for 64-bit Windows. That was the source of this issue. In addition, the installed JRE needs to be working!