Ask Your Question
1

Libreoffice 3.6.0 always crash after install. Why? [closed]

asked 2012-08-08 23:13:23 +0100

vjsouza gravatar image

updated 2015-10-17 15:22:34 +0100

Alex Kemp gravatar image

Hello. I was very happy with LibreOffice 3.5.4, and did not know I was happy! So, uninstalled version 3.5.4, downloaded and installed version 3.6.0. Then my problems started.

I always have problems in start the program. The system return a popup message: Fatal Error. Unhandled exception: InvalidRegistryException: file///C:Program%20......

Now, I no longer have the installers of the stable version 3.5.4

I think you should try at least test the program before releasing it to the public. This would avoid this embarrassing fiasco.

I think my solution is to download Apache OpenOffice 3.4.0, and try to be happy again!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-17 19:40:42.048026

16 Answers

Sort by » oldest newest most voted
4

answered 2012-08-09 14:45:34 +0100

Marcus gravatar image

updated 2012-08-09 14:46:58 +0100

It has been suggested numerous times here that deleting the user profile is a solution to this problem. See a description on how to do this here: http://wiki.documentfoundation.org/UserProfile

For those considering the solution of deleting the user profile, I'd like to add that in my case it was sufficient to delete the "extensions" subdirectory of the user profile. This might be handy information for people who want to keep most of their user profile and still update.

If you don't care about the user profile (you may need to set some settings again the way you want them), you can safely delete it though.

edit flag offensive delete link more

Comments

2

Related bugs: • fdo#53006fdo#51252fdo#43989fdo#50552 — removing the directory "extensions" (see above) should be a sufficient workaround. The bug will be fixed in version 3.6.1.

manj_k gravatar imagemanj_k ( 2012-08-09 18:36:59 +0100 )edit

Fixed in LO 3.6.1

manj_k gravatar imagemanj_k ( 2013-02-19 16:54:12 +0100 )edit
0

answered 2012-08-11 01:36:25 +0100

DrTeeth gravatar image

updated 2012-08-11 01:37:16 +0100

I have installed v3.6.0 on four PCs (Win 7 32 and 64 bit) and after install, each one has crashed with the same error about 'Uno' something or another. The fix was the same in each case and works 100%...just repair the installation.

It's annoying that after fixing the installer to find the current (user defined) install folder, it now defaults to something else and has to be (once again) manually changed - the help files do not have this issue (they used to).

DrTeeth

edit flag offensive delete link more
0

answered 2012-08-09 10:44:29 +0100

tohuwawohu gravatar image

Here: no problems installing 3.6 with 3.5.5 previously installed, everything works like a charm. I even didn't need to remove 3.5.5 before installing 3.6. System: Win7 64bit.

edit flag offensive delete link more
0

answered 2012-08-09 15:34:39 +0100

jeses gravatar image

Thanks Marcus, that helped. Deleting the profile was not an option for me, to many settings. But just deleting the extentions folder solved everything.

edit flag offensive delete link more
0

answered 2012-08-09 03:15:00 +0100

rdny gravatar image

I'm uninstalling 3.6 and I will delete the LO folders left after the uninstall, following the instructions from the link. It will take more than 10 minutes on my W7U 64bit 4Gb RAM. Suggestion since this is not a regular process for a regular user: why not creating a batch file that clean up everything after backing up those personal files and restoring them after reinstalling LO. I hope this will work.

edit flag offensive delete link more
0

answered 2012-08-09 02:13:49 +0100

rdny gravatar image

Same problem here. I agree you should test before releasing to the public. It is like you trying to promote moving users back to Microsoft instead of receiving the benefits of LO. By the way the previous version was crashing for not finding Java which was install. I thought that with this update my problems were gone. On the contrary they worsen.

edit flag offensive delete link more
0

answered 2012-08-09 06:59:49 +0100

KN gravatar image

Got it working on Win 7 32 bit Sp1:

Step 1: I uninstalled all Libre Office.

Step 2: I renamed the folder on Windows 7 from "C:\Users\<user>\Application Data\libreoffice\3" to "C:\Users\<user>\Application Data\libreoffice\3_OLD".

Step 3: Resinstalled the 3.6 (Version 3.6.0.4 (Build ID: 932b512)) version.

Step 4: Delete the 3_OLD folder and Enjoy :)

Note: You need to permissions to view System Folders or you can just copy paste the path from above. Don't forget to replace the <user> with your login name.

edit flag offensive delete link more
0

answered 2012-08-09 10:25:17 +0100

pidg gravatar image

dont know if it helps anyone i have installed Libre office 3.6 ok (English-GB Version) no problems at all over the top of a version i had installed not sure which version that was though and it runs ok

from libre writer help/about libre office/Version 3.6.0.4 (Build ID: 932b512)

win7 32bit ultimate afaik no sp1

edit flag offensive delete link more
0

answered 2012-08-20 23:04:18 +0100

DaveK gravatar image

Yet another solution

I got the error - Unhandled exception: Invalid Registry Exception: file:///C:Program%20Files%20(x86)/LibreOffice%203.6/program /.../share/extensions/wiki-publisher/components.rdb:duplicate <implementation name="com.sun.star.wiki.WikiOptionsEventHandlerImpl">

after installing 3.6 from 3.5.3. I tried the usual, reinstall, repair, uninstall, reinstall, reboot but still that error. I also tried removing the 3.6 directory in Program Files(x64)but no luck. I uninstalled 3.6, installed 3.5.6 which worked and then installed 3.6. It worked!

edit flag offensive delete link more
0

answered 2012-08-09 01:43:48 +0100

djl gravatar image

same problem: unhandled exception: InvalidRegistryException: file:///C:/Program%20Files/LibreOffice%203.6/program/../share/extensions/NLPSolver/components.rdb: duplicate <implementation name="com.sun.star.comp.Calc.NLPSolver.DEPSSolverImpl">

then

Microsoft Visual C++ Runtime Library Runtime Error!......

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2012-08-08 23:13:23 +0100

Seen: 6,157 times

Last updated: Aug 20 '12