Ask Your Question
1

Libreoffice 3.6.0 always crash after install. Why? [closed]

asked 2012-08-08 23:13:23 +0200

vjsouza gravatar image

updated 2015-10-17 15:22:34 +0200

Alex Kemp gravatar image

Hello. I was very happy with LibreOffice 3.5.4, and did not know I was happy! So, uninstalled version 3.5.4, downloaded and installed version 3.6.0. Then my problems started.

I always have problems in start the program. The system return a popup message: Fatal Error. Unhandled exception: InvalidRegistryException: file///C:Program%20......

Now, I no longer have the installers of the stable version 3.5.4

I think you should try at least test the program before releasing it to the public. This would avoid this embarrassing fiasco.

I think my solution is to download Apache OpenOffice 3.4.0, and try to be happy again!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-17 19:40:42.048026

16 Answers

Sort by » oldest newest most voted
4

answered 2012-08-09 14:45:34 +0200

Marcus gravatar image

updated 2012-08-09 14:46:58 +0200

It has been suggested numerous times here that deleting the user profile is a solution to this problem. See a description on how to do this here: http://wiki.documentfoundation.org/UserProfile

For those considering the solution of deleting the user profile, I'd like to add that in my case it was sufficient to delete the "extensions" subdirectory of the user profile. This might be handy information for people who want to keep most of their user profile and still update.

If you don't care about the user profile (you may need to set some settings again the way you want them), you can safely delete it though.

edit flag offensive delete link more

Comments

2

Related bugs: • fdo#53006fdo#51252fdo#43989fdo#50552 — removing the directory "extensions" (see above) should be a sufficient workaround. The bug will be fixed in version 3.6.1.

manj_k gravatar imagemanj_k ( 2012-08-09 18:36:59 +0200 )edit

Fixed in LO 3.6.1

manj_k gravatar imagemanj_k ( 2013-02-19 16:54:12 +0200 )edit
0

answered 2012-08-08 23:35:13 +0200

emdot gravatar image

Same problem here. Windows 7 Home Premium 64bit. After the first error-message there is a second one:

Microsoft Visual C++ Runtime Library Rutime Error! Program: C:\Program Files (x86)\LibreOffice 3.6 [...]

edit flag offensive delete link more
0

answered 2012-08-09 01:43:48 +0200

djl gravatar image

same problem: unhandled exception: InvalidRegistryException: file:///C:/Program%20Files/LibreOffice%203.6/program/../share/extensions/NLPSolver/components.rdb: duplicate <implementation name="com.sun.star.comp.Calc.NLPSolver.DEPSSolverImpl">

then

Microsoft Visual C++ Runtime Library Runtime Error!......

edit flag offensive delete link more
0

answered 2012-08-09 01:46:09 +0200

Ambimom gravatar image

updated 2012-08-09 02:31:42 +0200

Have exactly the same issue.

Unhandled exception: Invalid Registry Exception: file:///C:Program%20Files%20(x86)/LibreOffice%203.6/program /.../share/extensions/wiki-publisher/components.rdb:duplicate <implementation name="com.sun.star.wiki.WikiOptionsEventHandlerImpl">

The solution is here: link text

You need to change the user profile in app data....Unfortunately you have to migrate the data but the software will work.

edit flag offensive delete link more
0

answered 2012-08-09 02:13:49 +0200

rdny gravatar image

Same problem here. I agree you should test before releasing to the public. It is like you trying to promote moving users back to Microsoft instead of receiving the benefits of LO. By the way the previous version was crashing for not finding Java which was install. I thought that with this update my problems were gone. On the contrary they worsen.

edit flag offensive delete link more
0

answered 2012-08-09 02:21:36 +0200

rdny gravatar image

Now is a new message after rebooting the computer. In the process of starting the application when it was one forth of loading its file a popup says: "LibreOffice 3.6 stopped working. A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available". And that's it. You are on your own. I'm running Windows 7 Ultimate 64 bit. Please guys, solve the problem ASAP. This is not a game. You promote this product as a trusted program for a lot of institutions and this is what we got? Please there are reports I have to finish and I don't want to end having to buy Microsoft's Office package. I can't believe this is happening.

edit flag offensive delete link more
0

answered 2012-08-09 02:51:34 +0200

jeses gravatar image

same problem here.... the link above to the user profile things was not helpful. would be great, if someone could provide a solution...

edit flag offensive delete link more
0

answered 2012-08-09 03:15:00 +0200

rdny gravatar image

I'm uninstalling 3.6 and I will delete the LO folders left after the uninstall, following the instructions from the link. It will take more than 10 minutes on my W7U 64bit 4Gb RAM. Suggestion since this is not a regular process for a regular user: why not creating a batch file that clean up everything after backing up those personal files and restoring them after reinstalling LO. I hope this will work.

edit flag offensive delete link more
0

answered 2012-08-09 03:54:01 +0200

rdny gravatar image

After 19 minutes of installation process of LO 3.6 I received a Microsoft .NET Framework error message. Unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately.... and so on... If you want I can paste the Details shown in this window. I will try to Continue and see what's happening. I did that and no other pop up message showed up. I started LO for the first time now. It doesn't crash on 25% loading. Two minutes after the starting window disappears and I have no clew what is going on. LO icon is not among the running programs. Four minutes and nothing. I decided to go and launch LO again. Five seconds and the main menu shows up. Text document opens, same for Presentation, Spreadsheet, Drawing and Formula. Finally Database shows up not crashing. Congratulations. The instructions on the link, for now, it worked after almost 35 minutes of work. This is an installation to remember.

edit flag offensive delete link more
0

answered 2012-08-09 06:59:49 +0200

KN gravatar image

Got it working on Win 7 32 bit Sp1:

Step 1: I uninstalled all Libre Office.

Step 2: I renamed the folder on Windows 7 from "C:\Users\<user>\Application Data\libreoffice\3" to "C:\Users\<user>\Application Data\libreoffice\3_OLD".

Step 3: Resinstalled the 3.6 (Version 3.6.0.4 (Build ID: 932b512)) version.

Step 4: Delete the 3_OLD folder and Enjoy :)

Note: You need to permissions to view System Folders or you can just copy paste the path from above. Don't forget to replace the <user> with your login name.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2012-08-08 23:13:23 +0200

Seen: 6,313 times

Last updated: Aug 20 '12