Ask Your Question
0

regular expressions within Calc's standard filters don't seem to work

asked 2015-02-23 00:36:01 +0200

BSaffron gravatar image

Using Calc, regular expressions used in the 'VALUE' field of standard filters don't seem work on my systems. (1st sys: English Ubuntu 14.04 + LibreOffice 4.2.7.2 ; 2nd sys/different machine : English Ubuntu 12.04 + LibreOffice 3.5.7.2). I have reg.expressions checkmarked both in "Tools>Options>LibreOffice Calc>Calculate" and also each time I re-start a standard filter "Data>Filter>Standard Filter> ... more". In the standard filter "VALUE' field - for example - if I enter (unquoted) C* - I am expecting to see results that return all values starting with C. But the operation returns nothing. On either machine, nothing is returned. I have many enteries beginning with "C..." Case is uncheckmarked in the dialogue.

What am I doing wrong? !!!

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2015-02-23 10:08:33 +0200

karolus gravatar image

Hallo

the Filtersetting are independent from →Tools→Options→...Calc→Calculate

the proper RegEx for starts with C should be C.*

edit flag offensive delete link more
0

answered 2015-02-27 09:02:28 +0200

BSaffron gravatar image

updated 2015-02-27 09:05:21 +0200

SOLVED. Thank you, karolus. Yes, user error. I need to review regular expression syntax more thoroughly. Thanks again.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-02-23 00:36:01 +0200

Seen: 526 times

Last updated: Feb 27 '15