Ask Your Question
1

how to autocorrect "Non-breaking spaces" to normal spaces

asked 2015-02-28 18:02:57 +0200

jeggy gravatar image

updated 2015-03-01 22:01:58 +0200

Really often when I copy text from a pdf file and insert into Writer I get "Non-breaking spaces" instead of the normal spaces. This is extremely annoying, my current fix is to copy that gray space and then use the "Find & Replace".

I was wondering if it is possible to autocorrect it directly when I insert it into my documents, so I won't ever see that annoying gray space?

[UPDATE]
Here's an example PDF file: pdf

Here's the output when using the paste opportunities:
Writer paste examples

edit retag flag offensive close merge delete

Comments

Could you please attach such an pdf-file to your question to allow testing?

ROSt52 gravatar imageROSt52 ( 2015-03-01 04:37:35 +0200 )edit

@jeggi - You are on Windows, aren't you?

Lupp gravatar imageLupp ( 2015-03-02 00:21:16 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2015-03-01 23:01:25 +0200

David gravatar image

What are you using for viewing your PDFs, and doing the "copy" operation?

At the moment, I'm on an old maching running Linux Mint 13 (LTS/Xfce; built on Ubuntu 12.04), with LibO Version: 4.4.1.2 / Build ID: 40m0(Build:2). Here are the results I get with your PDF, but using three different PDF readers:

pdf-copy

All are straight copy-paste, with no interventions. I only get your result with qpdfview.

edit flag offensive delete link more

Comments

Also the Foxit Reader does not produce the problem when pasting a therefrom copied text into a Writer document. Styles are simply ignored..Pasting the text copied from the built-in pdf viewer of Firefox does show the effect and some issues in addition, even inserting paragraph marks. I should conclude: We are experiencing a problem with regard to the source application and, maybe, to the clipboard. How Writer takes part in it (and if at all) isn't clear.

Lupp gravatar imageLupp ( 2015-03-01 23:28:17 +0200 )edit

I'm using the Google Chrome pdf reader, don't really know which one that is. And I'm on Linux Mint 17.1. But I think this also happens on Windows 8 if copying from Chome pdf reader and directly into Writer

jeggy gravatar imagejeggy ( 2015-03-01 23:58:26 +0200 )edit
0

answered 2015-03-01 04:37:48 +0200

ROSt52 gravatar image

I would use Paste Special > Unformated text.

edit flag offensive delete link more

Comments

If I paste the unformatted text copied from the Firefox built-in viewer I (surprising for me!) don't get non-breaking spaces but wrong "new paragraph" occurrences.Remarkable: From the same viewer copying part of the OASIS odf document (in pdf) I also get wrong paragraph marks despite the fact that that pdf file is supposed to be created from the odt file (with LibreOffice?). It's a puzzle with viewers and the clipboard in the center, as I suppose.

Lupp gravatar imageLupp ( 2015-03-02 00:21:37 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-02-28 18:02:57 +0200

Seen: 708 times

Last updated: Mar 01 '15