Ask Your Question

I found it ... but now what :-s [closed]

asked 2015-03-04 01:51:56 +0200

LibreGuy gravatar image

In this topic (unfortunately I can't respond to it anymore) I stated that a document assigned to a certain template didn't update after changing that template. I finally found out what is causing it. It seems to be a bug.

What happened is that I don't want meta data like "editing time" and "revision" to be visible to other people when they look at one of my document properties. In LibreOffice "Security" options, there is a section "Security Options and Warnings". By enabling the option "Remove personal information on saving" this meta data is not recorded. You can have hundreds of revisions of a document and spend hundreds of hours working on it. The meta dat will show revision number 1 and a total editing time of 00:00:00. Great, exactly how I want it. BUT ... enabling this setting is what causes the document not to update after its template has changed. Maybe (but not sure) this has something to do with not being able to compare the "last updated timestamp" from both the template and the document. So the document does not "see" that the template has changed. I am just guessing here.

Allright ... so in order to update my documents after changing a template, I must disable this specific security setting, but now my metadata is being recorded ... which I do not want to happen. Is there another way to disable tracking the revision number and editing time? Is there maybe an expert configuration setting I could adjust to disable this behavior? Any help or ideas/suggestions will be very much appreaciated. Thanks in advance.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-08-16 21:43:49.785840

3 Answers

Sort by » oldest newest most voted

answered 2015-03-04 11:02:45 +0200

pierre-yves samyn gravatar image

Hi - Congratulations, you found the explanation of the problem.

My suggestion is to reverse your logic: keep the security option unchecked and, when saving a document to be sent to other users, do File > Properties and click Reset (you also can uncheck Apply user data before clicking)

edit flag offensive delete link more

answered 2015-03-04 06:43:14 +0200

ROSt52 gravatar image

(unfortunately I can't respond to it anymore)

Let me answer to this only. It seems you tried to create new answer, This is not possible but you can add comments or edit your question or your answer.

edit flag offensive delete link more

answered 2015-03-04 12:14:57 +0200

LibreGuy gravatar image

I could do that, but chances are I simply forget to do that. Is there another, permanent solution? Can I stop the tracking of the revision number/editing time by changing an expert configuration setting maybe?

Would it maybe be possible to record a macro which pushes the reset button and saves the file and then have that macro automatically be executed when I close a document? Is that an option, or do i have too much imagination right now?

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-03-04 01:51:56 +0200

Seen: 151 times

Last updated: Mar 04 '15