Ask Your Question
0

Calc - cell background color not visible on active spreadsheet

asked 2015-03-28 20:21:36 +0200

chiropterist gravatar image

updated 2015-03-29 20:39:36 +0200

Using Windows 7, 64bit (English) and Libre Office 4.4.1.2 clean install, Calc (English).

STEP 1: When I set a cell background color in Calc with Format > Cells > Background

OUTCOME 1 (unexpected): No cell background color appears on active spreadsheet

OUTCOME 2: Color does appear on File > Print Preview view

OUTCOME 3: Color does appear on File > Preview in Web Browser view

OUTCOME 4: Color does appear on Start Center (soffice.exe) view

How can I get cell background color to appear on active spreadsheet?

Am I doing something wrong or is this a bug?

edit retag flag offensive close merge delete

Comments

How did you set the backgroud color? Please explain each step with its result to allow simulations.

ROSt52 gravatar imageROSt52 ( 2015-03-29 06:30:36 +0200 )edit

Not able to reproduce on Win7 32-bit. There is a background option for the whole page (Format --> Page) that would give variable appearance similar to described, could check that. But that would match description only if formatting was imposed for page instead of cell. Sometimes there might be paragraph-level formatting for a background too, but do not see adverse function in Calc concering that either.

doug gravatar imagedoug ( 2015-03-29 22:36:18 +0200 )edit

@doug - Do you mean that on Win7 32-bit, you can see the cell background color on the active spreadsheet? (Format > Page > Background displays same behavior as I described for Format > Cells > Background, but my concern is with visibility of individual cell background colors.)

chiropterist gravatar imagechiropterist ( 2015-03-29 22:46:25 +0200 )edit

If you set the page format for color, and then set the cell format for white, you would see similar adverse functionality. I just checked on Win7 64-bit, also unable to reproduce there also.

doug gravatar imagedoug ( 2015-03-30 14:46:32 +0200 )edit

Can we please try this another way?

Could someone please tell me what are the steps to have cell background color appear on working spreadsheet?

Your help is greatly appreciated.

chiropterist gravatar imagechiropterist ( 2015-03-30 16:16:26 +0200 )edit

I think you described them. To attempt to reproduce I right mouse clicked in a cell and said Format Cell and when to the Background tab. Same is available from menu Format --> Cells. In either window, click on a color and go.

doug gravatar imagedoug ( 2015-03-30 16:20:45 +0200 )edit

To everyone who helped me, THANKS. I found the culprit and it is . . . wait for it . . . M$. Please see my answer to my own question, below.

chiropterist gravatar imagechiropterist ( 2015-03-31 19:14:22 +0200 )edit

glad it works ... but it was the solution I mentioned in my previous comment :)

pierre-yves samyn gravatar imagepierre-yves samyn ( 2015-04-01 12:04:35 +0200 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2015-03-31 20:51:27 +0200

chiropterist gravatar image

updated 2015-03-31 20:52:07 +0200

If you are using M$ Windows, and no cell background color appears on the active spreadsheet, be sure you are not using a “High Contrast” theme.

Try this (it worked for me on Windows 7 Pro 64-bit):

Go to Control Panel > All Control Panel Items > Personalization (OR Control Panel > Category > Appearance and Personalization > Personalization)

Choose any theme EXCEPT the High Contrast themes.

If you want a theme that has a high-contrast look, you will have to set one up yourself (thanks, M$).

This link may help you get started: sevenforums.com/tutorials/2026-theme-pack-create-save-install-delete.html.

Have fun.

edit flag offensive delete link more
0

answered 2015-03-29 13:34:03 +0200

pierre-yves samyn gravatar image

Hi

You could try (un)check options:

Tools > Options > LibreOffice >View > Graphics Output: Use hardware... & OpenGL...

or

Tools > Options > Accessibility > Options for high contrast: Automatically detect...

Regards

edit flag offensive delete link more

Comments

I tried these, thanks, but they didn't work. What did work, though, to make cell background color appear on File > Print Preview view was to UNCHECK Tools > Options > Accessibility > Use system colors for page preview. But this still doesn't make cell background color appear on the active spreadsheet.

chiropterist gravatar imagechiropterist ( 2015-03-29 18:36:58 +0200 )edit
1

Well .. I never encountered this problem on windows 7/64 (also tested with 4.4.2.1 locale: fr_FR).

Do you use a particular windows theme (particularly high contrasts)? Have you tried a different theme?

Further details in case: I guess you get the problem for all spreadsheets? And also with Writer?

pierre-yves samyn gravatar imagepierre-yves samyn ( 2015-03-30 09:09:05 +0200 )edit
0

answered 2017-09-13 18:09:19 +0200

updated 2017-09-13 18:10:50 +0200

Had this on PC with W7 Pro 64bit & virtual XP. Colours were OK on the XP side, showing no colours on the W7 side with the same spreadsheet. Go to Control Panel > All Control Panel Items > Personalization (OR Control Panel > Category > Appearance and Personalization > Personalization) changed theme to W7 theme, worked immediately. Thanks chiropterist

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-03-28 20:21:36 +0200

Seen: 845 times

Last updated: Sep 13