Calc - cell background color not visible on active spreadsheet

Using Windows 7, 64bit (English) and Libre Office clean install, Calc (English).

STEP 1: When I set a cell background color in Calc with Format > Cells > Background

OUTCOME 1 (unexpected): No cell background color appears on active spreadsheet

OUTCOME 2: Color does appear on File > Print Preview view

OUTCOME 3: Color does appear on File > Preview in Web Browser view

OUTCOME 4: Color does appear on Start Center (soffice.exe) view

How can I get cell background color to appear on active spreadsheet?

Am I doing something wrong or is this a bug?

How did you set the backgroud color? Please explain each step with its result to allow simulations.

Not able to reproduce on Win7 32-bit. There is a background option for the whole page (FormatPage) that would give variable appearance similar to described, could check that. But that would match description only if formatting was imposed for page instead of cell. Sometimes there might be paragraph-level formatting for a background too, but do not see adverse function in Calc concering that either.

@doug - Do you mean that on Win7 32-bit, you can see the cell background color on the active spreadsheet? (Format > Page > Background displays same behavior as I described for Format > Cells > Background, but my concern is with visibility of individual cell background colors.)

If you set the page format for color, and then set the cell format for white, you would see similar adverse functionality. I just checked on Win7 64-bit, also unable to reproduce there also.

Can we please try this another way?

Could someone please tell me what are the steps to have cell background color appear on working spreadsheet?

Your help is greatly appreciated.

I think you described them. To attempt to reproduce I right mouse clicked in a cell and said Format Cell and when to the Background tab. Same is available from menu FormatCells. In either window, click on a color and go.

To everyone who helped me, THANKS. I found the culprit and it is . . . wait for it . . . M$. Please see my answer to my own question, below.

glad it works … but it was the solution I mentioned in my previous comment :slight_smile:

If you are using M$ Windows, and no cell background color appears on the active spreadsheet, be sure you are not using a “High Contrast” theme.

Try this (it worked for me on Windows 7 Pro 64-bit):

Go to Control Panel > All Control Panel Items > Personalization (OR Control Panel > Category > Appearance and Personalization > Personalization)

Choose any theme EXCEPT the High Contrast themes.

If you want a theme that has a high-contrast look, you will have to set one up yourself (thanks, M$).

This link may help you get started:

Have fun.


You could try (un)check options:

Tools > Options > LibreOffice >View > Graphics Output: Use hardware… & OpenGL…


Tools > Options > Accessibility > Options for high contrast: Automatically detect…


I tried these, thanks, but they didn’t work.
What did work, though, to make cell background color appear on File > Print Preview view was to UNCHECK Tools > Options > Accessibility > Use system colors for page preview. But this still doesn’t make cell background color appear on the active spreadsheet.

Well … I never encountered this problem on windows 7/64 (also tested with locale: fr_FR).

Do you use a particular windows theme (particularly high contrasts)? Have you tried a different theme?

Further details in case: I guess you get the problem for all spreadsheets? And also with Writer?

Had this on PC with W7 Pro 64bit & virtual XP. Colours were OK on the XP side, showing no colours on the W7 side with the same spreadsheet. Go to Control Panel > All Control Panel Items > Personalization (OR Control Panel > Category > Appearance and Personalization > Personalization) changed theme to W7 theme, worked immediately.
Thanks chiropterist

I had a comparable case in Calc, with LO 5.1.6 on Ubuntu 64 bit, with Intel graphics driver. Ensured that OpenGL and hardware acceleration are disabled and also, that in the accessibility options, there were no “high contrast” settings activated.

Yet, cell values were showing up black, instead of their assigned custom color. The custom text colour assigned to an entire column indeed showed up ONLY if I clicked inside of a cell; it also had the correct colour in print (including preview) and in exported PDFs.

In the main menu, disabling (“unchecking”)

View > Value Highlighting

solved it. Now I see the assigned color as intended.