Ask Your Question
2

Where does LO store keyboards/shortcuts? [closed]

asked 2012-08-19 16:18:11 +0200

Dreamdeer gravatar image

Okay, I think I know where I went wrong with the keyboard fiasco, but I need help setting it right. The reason my navigation arrows and backspace stopped working might be that when I tried to create shortcuts to accented vowels, I saw the "load" button and thought it meant that I could create a file with each letter ad load it in for each designated shortcut. So I made a "Special Character" file for these. But now I think that Libre Office thinks that's where to store keyboard configurations, but can't tap into it, so all of the shortcut keys have disappeared--including basic navigational keys like the arrows.

The question is, where is the right file location, and how do I get it back? Or am I barking up the wrong tree?

This is rather urgent as I've got a deadline in the balance, on 8/21.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-17 19:53:59.193943

Comments

This question is a follow-up of → My Navigation Keys Quit.

manj_k gravatar imagemanj_k ( 2013-03-02 14:02:47 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2012-08-19 18:22:47 +0200

manj_k gravatar image

Customized keyboard shortcuts are stored in your LibreOffice user profile,
configuration file "registrymodifications.xcu",
path "%appdata%\LibreOffice\3\user\registrymodifications.xcu".

Backup the original file "registrymodifications.xcu".
Open the file "registrymodifications.xcu" with a text editor.
Search for keyword "Accelerators".
Remove all entries, beginning with:
<item oor:path="/org.openoffice.Office.Accelerators/...>...</item>.

Save the file.
That should restore the default values.

Sample 1

<item oor:path="/org.openoffice.Office.Accelerators/PrimaryKeys/Global">
 <node oor:name="U_MOD1" oor:op="replace">
  <prop oor:name="Command" oor:op="fuse">
   <value xml:lang="en-US">vnd.sun.star.script:Standard.Module1.paste_unformatted?language=Basic&location=application</value>
  </prop>
 </node>
</item>

<item oor:path="/org.openoffice.Office.Accelerators/PrimaryKeys/Modules/org.openoffice.Office.Accelerators:Module['com.sun.star.text.TextDocument']">
 <node oor:name="8_SHIFT_MOD1_MOD2" oor:op="replace">
  <prop oor:name="Command" oor:op="fuse">
   <value xml:lang="en-US">.uno:StyleApply?Style:string=d_fr&FamilyName:string=CharacterStyles</value>
  </prop>
 </node>
</item>

Sample 2

Sample 2

Sample 3

Sample 3

edit flag offensive delete link more
0

answered 2012-08-19 20:51:23 +0200

Dreamdeer gravatar image

Thank you and bless you! I will try this immediately!

edit flag offensive delete link more

Comments

Nope. It still does not work. Something else must have gone wrong.

Dreamdeer gravatar imageDreamdeer ( 2012-08-19 21:30:44 +0200 )edit

Nothing I do works. None of the shortcut keys work. I don't know what to do, and apparently nobody else does, either. I'll have to find some other program, I guess.

Dreamdeer gravatar imageDreamdeer ( 2012-08-20 06:18:27 +0200 )edit
1

You may try:

  1. Close LibreOffice (+ Quickstarter, if enabled)
  2. Rename "registrymodifications.xcu" to "registrymodifications_old.xcu"
  3. Restart LibreOffice
  4. Menu File → New → Text Document
  5. Type some text
  6. Check the shortcut keys.
manj_k gravatar imagemanj_k ( 2012-08-20 10:55:43 +0200 )edit

Have you found any 'item oor:path=/org.openoffice.Office.Accelerators/...' in your original "registrymodifications.xcu"? — Have you closed LibreOffice (+ Quickstarter) before editing your original "registrymodifications.xcu"?

manj_k gravatar imagemanj_k ( 2012-08-20 11:00:27 +0200 )edit

@manj_k -- I guess we won't meet the 8/21 deadline here... Thoughts on what we should do with this question? Your Answer is very detailed..

qubit gravatar imagequbit ( 2013-02-22 08:43:20 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2012-08-19 16:18:11 +0200

Seen: 1,448 times

Last updated: Aug 19 '12