Ask Your Question
0

Libreoffice crashes explorer.exe on Windows 7 [closed]

asked 2012-08-22 21:12:20 +0200

desto gravatar image

updated 2015-08-24 18:02:38 +0200

Alex Kemp gravatar image

Hi! I've been trying to use libreoffice in my windows 7 work PC for personal use, but every single time I've tried to do so, right before the installer finishes, explorer.exe goes nuts and crashes, and then starts again, only to crash 2 seconds later, and it repeats for ever unless I kill explorer via command. If I start libreoffice, it starts correctly but explorer.exe keeps crashing. I really have no clue as to why this happens, but as soon as I uninstall libreoffice, all returns to normal.

I tried searching for any possible solutions, but I haven't found anyone with a similar problem as mine, so I'm posting it here, hoping someone could help.

Thanks!

Edit: Forgot to mention, this happens with the 3.6 LibreOffice version, on a x86 system.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-17 23:00:03.637689

Comments

@vsfoote I tried doing a custom installation without shell integration, but it still hangs my explorer.exe.

desto gravatar imagedesto ( 2012-08-27 17:50:01 +0200 )edit

@desto prior to the custom reinstall, when uninstalling did you clear out your old profile?

vsfoote gravatar imagevsfoote ( 2012-08-29 18:52:26 +0200 )edit

@vsfoote I did, uninstalled with revo and deleted all traces of the app.

desto gravatar imagedesto ( 2012-09-03 17:16:20 +0200 )edit

@desto including your per-user folder and possibly any Windows registry entries (although Revo should have gotten these)?

vsfoote gravatar imagevsfoote ( 2012-09-04 17:31:02 +0200 )edit

Also, how much room do you have in your Windows registry? Have you expanded it to unlimited size with a RegistrySizeLimit value of Hex 0xffffffff (enter as eight 'f's) in the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control key?

vsfoote gravatar imagevsfoote ( 2012-09-04 17:34:55 +0200 )edit

3 Answers

Sort by » oldest newest most voted
2

answered 2012-08-23 05:25:09 +0200

vsfoote gravatar image

I agree with @manj_k that the problem may be related to the shlxthdl_x64.dll/shlxthdl.dll bugs fdo#52078, fdo#53533 and fdo#53534. With patch in the works for 3.6.1& 3.7 builds.

Workaround now is to perform a custom installation of 3.5.x and 3.6.0--and you can deselect installation of the Windows Explorer shell extension. Believe that eliminates the issue of crashing the Windows Explorer shell until it can be patched.

edit flag offensive delete link more

Comments

Current status of these bugs:

fdo#52078 - REOPENED
fdo#53533 - RESOLVED FIXED
fdo#53534 - NEW
qubit gravatar imagequbit ( 2013-02-22 09:26:15 +0200 )edit
1

answered 2012-08-22 22:22:30 +0200

manj_k gravatar image
edit flag offensive delete link more
0

answered 2012-09-03 17:18:14 +0200

desto gravatar image

No matter what I do, it always ends up crashing explorer.exe. I am running the portable version now but it seems sluggish when it starts (it takes a while). Would be great if I could install it but it won't work for me.

edit flag offensive delete link more

Comments

1

My personal workaround: I've renamed the folder "shlxthdl" (path: ...\LibreOffice 3.6\program\shlxthdl) to "shlxthdl_1", and then I've replaced it with "shlxthdl" from LibreOffice 3.5.6. That repaired the severe retardation of 'Windows explorer' (on WinXP 32b).

manj_k gravatar imagemanj_k ( 2012-09-05 12:02:59 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2012-08-22 21:12:20 +0200

Seen: 2,934 times

Last updated: Sep 04 '12