Libreoffice crashes explorer.exe on Windows 7

Hi! I’ve been trying to use libreoffice in my windows 7 work PC for personal use, but every single time I’ve tried to do so, right before the installer finishes, explorer.exe goes nuts and crashes, and then starts again, only to crash 2 seconds later, and it repeats for ever unless I kill explorer via command.
If I start libreoffice, it starts correctly but explorer.exe keeps crashing. I really have no clue as to why this happens, but as soon as I uninstall libreoffice, all returns to normal.

I tried searching for any possible solutions, but I haven’t found anyone with a similar problem as mine, so I’m posting it here, hoping someone could help.


Forgot to mention, this happens with the 3.6 LibreOffice version, on a x86 system.

@vsfoote I tried doing a custom installation without shell integration, but it still hangs my explorer.exe.

@desto prior to the custom reinstall, when uninstalling did you clear out your old profile?

@vsfoote I did, uninstalled with revo and deleted all traces of the app.

@desto including your per-user folder and possibly any Windows registry entries (although Revo should have gotten these)?

Also, how much room do you have in your Windows registry? Have you expanded it to unlimited size with a RegistrySizeLimit value of Hex 0xffffffff (enter as eight 'f’s) in the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control key?

I agree with @manj_k that the problem may be related to the shlxthdl_x64.dll/shlxthdl.dll bugs fdo#52078, fdo#53533 and fdo#53534. With patch in the works for 3.6.1& 3.7 builds.

Workaround now is to perform a custom installation of 3.5.x and 3.6.0–and you can deselect installation of the Windows Explorer shell extension. Believe that eliminates the issue of crashing the Windows Explorer shell until it can be patched.

Current status of these bugs:

fdo#52078 - REOPENED
fdo#53533 - RESOLVED FIXED
fdo#53534 - NEW

LibreOffice 3.6.x?
Maybe related to → Bug 52078 - shlxthdl_x64.dll/shlxthdl.dll causes Windows Explorer to CRASH repeatedly when Flat ODF file is in view.

No matter what I do, it always ends up crashing explorer.exe. I am running the portable version now but it seems sluggish when it starts (it takes a while). Would be great if I could install it but it won’t work for me.

My personal workaround: I’ve renamed the folder "shlxthdl" (path: ...\LibreOffice 3.6\program\shlxthdl) to "shlxthdl_1", and then I’ve replaced it with "shlxthdl" from LibreOffice 3.5.6. That repaired the severe retardation of ‘Windows explorer’ (on WinXP 32b).