Ask Your Question
1

Why does direct clear formatting not clear character style

asked 2015-06-11 06:31:31 +0200

Bruno Mendoza gravatar image

updated 2015-08-25 18:46:06 +0200

Alex Kemp gravatar image

Official LO Writer wiki says you can use "direct clear formatting" tool to clear character style from text but you don't.

What's wrong?

I use LO 4.3.7.2 for OS X and LO 4.2 for Linux

Thanks.

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
0

answered 2015-06-12 00:38:02 +0200

Lupp gravatar image

updated 2015-06-12 00:50:54 +0200

'Clear Direct Formatting', whether called by the shortcut Ctrl+M or in another way, does not set a default style. It simply clears format properties directly applied, mostly using one or another iconised tool or one of the format dialogues. The alternative to direct formatting is applying named styles. Format properties assigned this way are not afflicted by the procedure under discussion.

NB Page styles do not work this way. This may be related to the lacking inheritance feature. Any changes to the current page format becomes part of the named style assigned to the page and cannot be made undone by Ctrl+M. In other words: There doesn't exist a direct formatting of pages.

edit flag offensive delete link more

Comments

That's not true. You can stop setting character style to a string using Direct Formatting Tool but you can't highlight some characters and removes its applied character style. This is very confusing.

Bruno Mendoza gravatar imageBruno Mendoza ( 2015-06-12 18:39:44 +0200 )edit
0

answered 2015-06-11 18:42:59 +0200

Bruno Mendoza gravatar image

Thanks Alex,

I thought "Clear Direct Formatting" returns all selected characters to "Default Style" character style even after set a different "Character Style" from "Styles and Formatting" panel.

edit flag offensive delete link more

Comments

You are correct, Bruno - that is my reading of the LO help.

In general use, I find that Ctrl-M will remove other styles & formatting & send the text back to the default style on the paragraph. However, I tried a little test just now & it did NOT remove any formatting at all, whether by toolbar or by character style. Good lord! Looks like yet another bug.

Alex Kemp gravatar imageAlex Kemp ( 2015-06-11 19:24:26 +0200 )edit

You surely selected a portion of text before calling the 'Clear direct formatting' tool?

Lupp gravatar imageLupp ( 2015-06-12 00:28:29 +0200 )edit

@Lupp I most surely did, yes. I've been watching this tool more closely since Bruno's question & my initial reply. It simply does not work in the manner that the LO Help says it should. Also, as you say in your answer, applying a paragraph style (even if that is the style already in force) is far quicker. Which is silly.

Alex Kemp gravatar imageAlex Kemp ( 2015-06-12 05:48:14 +0200 )edit

"Clear Formatting Tool" removes character styles but it makes only in one way. Look at this link text

Bruno Mendoza gravatar imageBruno Mendoza ( 2015-06-12 18:24:41 +0200 )edit
0

answered 2015-06-11 13:10:54 +0200

Alex Kemp gravatar image

Hi Bruno Mendoza

You are talking about:-

  • menu:- Format - Clear Direct Formatting
  • command:- Ctrl+M

I use LO-4.4.3.2 under Linux & cannot confirm your report, Bruno (sorry). It works as expected for me, which is to return the formatting to the defaults of the style currently in force.

From the LO downloadable help text:-

Clear Direct Formatting

Removes direct formatting and formatting by character styles from the selection. Direct formatting is formatting that you applied without using styles, such as setting bold typeface by clicking the Bold icon.

edit flag offensive delete link more
0

answered 2015-06-12 09:18:19 +0200

pierre-yves samyn gravatar image

Hi

As @Lupp said, it is not a bug but the expected behavior. Help has unfortunately not been updated and describes the former operation inherited OOo.

See tdf#31394

Regards

edit flag offensive delete link more

Comments

But... if you are writing some text, stop and set some character style, add some more characters to your text and then use "clear direct formatting" tool it will change character style to default.

Look at this video link text

Bruno Mendoza gravatar imageBruno Mendoza ( 2015-06-12 18:22:48 +0200 )edit

I see what you mean, but context is different. Clear direct... (or Ctrl+M) returns to the default style for what will be typed after. What I mentioned is different: select already typed text, use Clear direct... remove bold applied with the format toolbar, not bold applied with Strong emphasis style.

pierre-yves samyn gravatar imagepierre-yves samyn ( 2015-06-12 18:48:01 +0200 )edit

Then official wiki help document about "direct formatting tool" is partly correct. You can remove a character style using "direct formatting tool" but you can't highlight a string and use this tool to remove character style applied to it. It's very confusing and I think it is a problem.

Bruno Mendoza gravatar imageBruno Mendoza ( 2015-06-12 19:17:30 +0200 )edit

It seems to me that this was the meaning of the second sentence of my answer :)

pierre-yves samyn gravatar imagepierre-yves samyn ( 2015-06-12 19:42:46 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2015-06-11 06:31:31 +0200

Seen: 768 times

Last updated: Jun 12 '15