Ask Your Question
0

unoconv makes all images anchored as character

asked 2015-07-08 20:21:49 +0200

rosamund gravatar image

updated 2015-08-24 18:49:03 +0200

Alex Kemp gravatar image

I'm on Windows, using unoconv with LibreOffice 5.0.0.0.beta3 to convert HTML files to RTF. (I tried LibreOffice 4, but whenever I try to use it with unoconv, it bombs.) I'm using an .ott template to help with the formatting. There's only one problem: all images end up anchored "as character," rather than "to paragraph," which means that they get jumbled together on top of each other. This is happening even though I have given both the default Graphic and Frame styles to "to paragraph" anchoring in the .ott file. In the converted rtf file, the default styles still have "to paragraph" anchoring; it's just that each individual image is set to anchor as a character.

The anchoring still gets set this way if I run unoconv without using the template, so it's not a weird defect in the .ott file. It also happens if I strip all CSS out of the HTML file.

Any idea what is going on and if there's something I can do to fix it?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2015-07-10 22:00:59 +0200

dag gravatar image

Have you tried doing the same using LibreOffice GUI ?

Since unoconv does not modify the content in any way, it must be related to limitations/regressions in HTML import filter or the RTF export filter. You can most likely see which is the problem by opening it yourself in LibreOffice manually.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2015-07-08 20:21:49 +0200

Seen: 175 times

Last updated: Jul 10 '15