We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question

Why can't I get "middle mouse button" action to "paste cilpboard" in LO

asked 2015-07-20 21:07:45 +0200

mrodmac gravatar image

updated 2020-07-10 14:30:12 +0200

Alex Kemp gravatar image, English, Writer Arch Linux, English

Tools -> Options -> LibreOffice -> View -> "Middle Mouse Button" is set to "Paste Clipboard" but clicking the middle mouse button always causes it to Auto-Scroll. What might I be doing wrong?

[edit: added lo5 + arch tags]

edit retag flag offensive close merge delete


OK, an update. The vast majority of middle mouse button pasting I do is from a terminal window or text editor. If I highlight text in a term window or text editor (medit, nedit) and middle click in Writer I get the autoscroll indicator. If I highlight text in a Writer document then middle click in a second Writer document I get the expected pasting. After that, I can paste from a terminal window or text editor just as in past versions of LO. Curiouser and curiouser.

mrodmac gravatar imagemrodmac ( 2015-08-04 15:21:41 +0200 )edit

4 Answers

Sort by » oldest newest most voted

answered 2015-08-19 17:57:50 +0200

Hi there!

got exactly the same issue. I remember it was not the case before version 5 it is disapointing as I use to copy and past a lot between terminal to LO

auto edit... apparently solved in 5.0.1

edit flag offensive delete link more

answered 2019-06-11 08:11:54 +0200

Is still an issue in Version Version: Build ID: 1:6.2.4-0ubuntu0.19.04.1 CPU threads: 16; OS: Linux 5.1; UI render: default; VCL: kde5; Locale: de-AT (en_US.UTF-8); UI-Language: en-US Calc: threaded I cannot copy via middle mouse-click. I have to transfer 100 of items to a webform, and selecting+ctrl-C takes 10 times longer.

edit flag offensive delete link more


Please reference a bug report you've filed on this.

Mike Kaganski gravatar imageMike Kaganski ( 2019-06-11 09:01:17 +0200 )edit

answered 2015-08-04 16:35:50 +0200

mrodmac gravatar image

I always thought it sad when a topic went uncommented on then was ultimately solved by the poster. This seems to be a problem with the LO start screen. When Writer is started from the start screen all the above issues exist. When Writer is started directly (/path/to/libreoffice5.0/programs/soffice --writer) it acts exactly as expected, middle mouse button pasting from any programs. Not solved but figured out.

edit flag offensive delete link more

answered 2015-08-21 17:29:44 +0200

davama gravatar image

This did not work for me. I also use copy/paste a lot with the term

libreoffice --version

LibreOffice 00m0(Build:5)

Had to rollback to libreoffice-still
LibreOffice 40m0(Build:2)

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower


Asked: 2015-07-20 21:07:45 +0200

Seen: 1,954 times

Last updated: Jun 11 '19