Why can't I get "middle mouse button" action to "paste cilpboard" in LO, English, Writer
Arch Linux, English

Tools → Options → LibreOffice → View → “Middle Mouse Button” is set to “Paste Clipboard” but clicking the middle mouse button always causes it to Auto-Scroll. What might I be doing wrong?

[edit: added lo5 + arch tags]

OK, an update. The vast majority of middle mouse button pasting I do is from a terminal window or text editor. If I highlight text in a term window or text editor (medit, nedit) and middle click in Writer I get the autoscroll indicator. If I highlight text in a Writer document then middle click in a second Writer document I get the expected pasting. After that, I can paste from a terminal window or text editor just as in past versions of LO. Curiouser and curiouser.

I always thought it sad when a topic went uncommented on then was ultimately solved by the poster. This seems to be a problem with the LO start screen. When Writer is started from the start screen all the above issues exist. When Writer is started directly (/path/to/libreoffice5.0/programs/soffice --writer) it acts exactly as expected, middle mouse button pasting from any programs. Not solved but figured out.

Hi there!

got exactly the same issue.
I remember it was not the case before version 5
it is disapointing as I use to copy and past a lot between terminal to LO

auto edit…
apparently solved in 5.0.1

This did not work for me. I also use copy/paste a lot with the term

libreoffice --version

LibreOffice 00m0(Build:5)

Had to rollback to libreoffice-still
LibreOffice 40m0(Build:2)

Is still an issue in Version
Build ID: 1:6.2.4-0ubuntu0.19.04.1
CPU threads: 16; OS: Linux 5.1; UI render: default; VCL: kde5;
Locale: de-AT (en_US.UTF-8); UI-Language: en-US
Calc: threaded
I cannot copy via middle mouse-click. I have to transfer 100 of items to a webform, and selecting+ctrl-C takes 10 times longer.

Please reference a bug report you’ve filed on this.