Ask Your Question
0

my font is not reconized 1 [closed]

asked 2015-07-22 12:06:55 +0100

kiniebaka gravatar image

updated 2020-08-23 09:46:14 +0100

Alex Kemp gravatar image

Hi all . I was wondering what am i doing wrong and LibreOffice writer is not recognizing my RTL fonts ?not to be confuse the fonts it is African writing forme Unicode
ߡߎ߲ ߠߋ߬ ߘߐ߫ ߟߌߓߥ ߵߏߝߌ߯ߛ strong text like is doing it wright now ?
but when i go to the writer all it displays is small squares . am using Version: 4.4.2.2 Build ID: 40m0(Build:2) Locale: en_US ubuntu 15.4 and usig this font ,kanjamadi1.ttf

thanks

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2020-08-23 09:47:45.784744

2 Answers

Sort by » oldest newest most voted
0

answered 2015-07-22 13:45:34 +0100

petermau gravatar image

It would be helpful to know which version of LibreOffice and language pack you are using and which operating system.

Small squares indicate that the font you have chosen does not contain the characters you need. You can check this by using INSERT > SPECIAL CHARACTERS > And choosing any of the characters displayed.

However, in order to write RTL you need to enable Complex Text Layout. On my English Linux system it is (TOOLS > OPTIONS > LANGUAGE SETTINGS > LANGUAGE > COMPLEX TEXT LAYOUT choose Language). The next time you start LibO you will get additional choices though I have not experience of those. You must also choose FONTS that contain the characters that you need. Hope this gets you started..Peter

edit flag offensive delete link more

Comments

thank you for answering to my problem i am using Version: 4.4.2.2 Build ID: 40m0(Build:2) Locale: en_US ubuntu 15.4 and usig this font /home/traore/Desktop/kanjamadi1.ttf

kiniebaka gravatar imagekiniebaka ( 2015-07-30 04:53:08 +0100 )edit
0

answered 2015-07-30 07:14:26 +0100

Alex Kemp gravatar image

You need to check that the font being used in the style applicable to that text is both UTF-8 + contains the glyphs for the characters that you are attempting to add. Try this:-

  1. Select some characters that all show squares (no glyphs)
  2. (menu):Format|Character...|Font
    Is that font kanjamadi1.ttf?
  3. (menu):Insert|Special Character... (select kanjamadi1.ttf)
    Is that character in that font at it's correct Unicode location?

If 'yes' & 'yes' then that is a bug in the program.

I'm concerned that your locale may not be utf-8; if Ubuntu then it should be (ubuntu is utf8 by default). As I understand LO it also is UTF-8 by default. That means that any font that is utf8 + contains glyphs for your chars in your language will work in LO.

For absolute best, the system locale & LO locale should be the same:-
see (menu):Tools|Options|Language Settings|Languages

You can check on your personal locale in a terminal (there's lots more than I show here):

:~$ locale
LANG=en_GB.UTF-8

If this helps then please tick the answer (✔).

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-07-22 12:06:55 +0100

Seen: 95 times

Last updated: Jul 30 '15