Ask Your Question
1

date format bringing up incorrect date result [closed]

asked 2012-09-03 00:04:02 +0200

damascusbarbie gravatar image

updated 2015-11-02 04:13:22 +0200

Alex Kemp gravatar image

I'm entering spreadsheet information, and when I stopped/saved last night everything was working perfectly. This morning I logged back on to continue entering the spreadsheet information, but now the formatting for the date column just isn't working at all. When I bring up "format" on the menu bar, select "cells", and select the format style (mm/dd/yy), the date I entered in the spreadsheet - 051811 - doesn't show in the format box OR the spreadsheet as 05/18/11 but as "11/06/41". I've tried using the format paintbrush, and also re-formatting the entire column, but I just can't get the date format to work correctly. I have tried entering ' before the 051811 but that hasn't helped, and I have also deleted several rows to remove any bad info/formatting, but that hasn't helped either. All other spreadsheet columns are OK.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-17 22:45:02.066890

2 Answers

Sort by » oldest newest most voted
1

answered 2012-09-03 17:38:15 +0200

w_whalley gravatar image

LibreOffice stores dates internally as a number. You can choose to display the number as a number or as a date. By default the dates start with number 0 on 1899-12-30 (iso date format). The number you had in your cell 051811 or 51811 corresponds to date 11/06/41 (2041-11-06 iso). When you applied a date format to the number 51811, you got the date you see.

If you enter the characters 051811 into a cell LO will interpret it as a number, and even if the cell is already formatted as a date, it will change the format to number and display 51811. If you reapply date format then you get 11/06/41.

Try entering the characters as 05/18/11 or 2011-05-18 instead. LO will recognize this as a date and change the cell format to date or leave it as date if it is already formatted that way.

edit flag offensive delete link more
0

answered 2012-09-03 22:05:42 +0200

TheoLinux gravatar image

updated 2012-09-03 22:07:30 +0200

Is the problem that you describe like this http://ask.libreoffice.org/question/4828/date-format-dont-work-after-upgrade-to-36-from-35/ Because, this is different from that w_whalley says. I tried to change the date format but even the date preview don't shows correctly in the cell format window.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-09-03 00:04:02 +0200

Seen: 2,297 times

Last updated: Sep 03 '12