Ask Your Question

Rich Text documents (.rtf) open in LibreOffice Calc' instead of Writer. Is there a solution? [closed]

asked 2015-08-14 22:37:05 +0200

Mangal gravatar image

updated 2020-09-15 22:53:58 +0200

Alex Kemp gravatar image

My Rich Text documents are opening 'Rich Text Document.rtf - LibreOffice Calc'. i.e. they have changed to a Spreaddsheet format. This is with existing or new any documents. I have recently upgraded to Windows 10. Is there a solution?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-09-15 22:54:25.121649

3 Answers

Sort by » oldest newest most voted

answered 2015-08-15 12:54:58 +0200

Mangal gravatar image

I right clicked on the corrupted document and clicked on 'Restore Previous Versions' and it's fixed the problem. Rich Text Document is now 'Rich Text Document' Previously it was .rtf file-name but it was a Spreadsheet when opened. Also it took many many minutes to open.

edit flag offensive delete link more

answered 2016-10-13 17:10:20 +0200

huels gravatar image

Same problem here. It opens correctly on calc, however if I try to open it with Writer this one show a "general I/O error".

edit flag offensive delete link more

answered 2016-01-24 17:50:39 +0200

I have the same problem. I am using Win 10 and LibreOffice thinks my rtf documents are spreadsheets! Using the 'Restore Previous Version' option suggested above allowed me to manually set it to open with Writer and not Calc.

However this is not a matter of a 'corrupted' document as all my old rtf files were now showing as spreadsheets, just like the original poster reported.

edit flag offensive delete link more


Try right-clicking on a .rtf document and selecting "open with...". Find and select LO Writer, and check "always use this program to open this type of document". Click OK.

paul1149 gravatar imagepaul1149 ( 2016-01-26 00:57:58 +0200 )edit

I just installed LibreOffice for the first time on a Windows 10 computer and this happened, This has never happened on a Windows 7 computer, and I have installed it on many. Anyway, the "Open with" fix worked.

pjc123 gravatar imagepjc123 ( 2016-01-29 22:04:10 +0200 )edit

Question Tools



Asked: 2015-08-14 22:37:05 +0200

Seen: 5,085 times

Last updated: Nov 25 '16