Ask Your Question

Extension Installation Could not create Java Implementation Loader [closed]

asked 2012-09-07 05:17:16 +0100

updated 2020-08-23 11:33:32 +0100

Alex Kemp gravatar image

I am unable to install many extensions due to the error 'Could not create Java Implementation Loader'. I have rechecked the java path etc and not having any luck. I tried un-checking the 'use java runtime' and that did not help. I would also like to know how to remove extensions that came bundled-I do not nee all the language extensions that are installed. Perhaps that is not possible. USing LibreOffice on Vista. Is it because I have Java tm 7 update 5 and JavaFX 2.1.1 installed? Thanks in advance.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-08-23 11:35:58.738566



LibO support Java 7, but (especially on 64-bit Windows) you might receive warnings about the Java version being defective. In that case, download and install the most current JRE 6 version . Make sure you get the file "Windows x86 Offline (32-bit)". Then configure LibO to use it at "Tools - Options - LibreOffice - Java"

Timon gravatar imageTimon ( 2012-09-07 06:19:05 +0100 )edit

A bit late maybe, but I suffered from the same. I could resolve it by selecting "Tools - Options... - LibreOffice - Advanced" and then selecting one of the possible JRE's that were installed on my computer (none were selected by default). I'm using LO

Juul gravatar imageJuul ( 2014-04-20 08:02:48 +0100 )edit

@Juul I registered just to say that 5 years later on LO V6.2.4.2 You fixed my problem, Thank you!!!

LadyNixie gravatar imageLadyNixie ( 2019-06-07 18:40:34 +0100 )edit

@Juul, many thx, I was able to solve the problem with your instructions.

Ricardo Quiroz gravatar imageRicardo Quiroz ( 2019-07-17 07:46:08 +0100 )edit

7 Answers

Sort by » oldest newest most voted

answered 2012-09-07 08:48:41 +0100

Well, I uninstalled the existing java, then installed java6. So far so good. This seems to have done the trick. Time will tell. Thank you for your help!

edit flag offensive delete link more


You are welcome

Timon gravatar imageTimon ( 2012-09-07 09:24:01 +0100 )edit

answered 2012-10-19 21:09:41 +0100

dnaber gravatar image

updated 2012-10-19 21:11:56 +0100

To avoid confusion, the exact error message is "Could Not Create Java Implementation Loader" ("loader", not "folder").

We now have a source-level analysis here.

The most successful workarounds are described here it seems.

edit flag offensive delete link more


Thanks. I have edited the question for clarity.

oweng gravatar imageoweng ( 2014-04-20 04:08:56 +0100 )edit

answered 2015-10-28 15:38:45 +0100

João Mac-Cormick gravatar image

1) exit LibreOffice and quickstart.exe

2) run cmd.exe (Prompt)

3) In Prompt, delete file "%appdata%\LibreOffice\4\user\user\extensions\buildid"

4) In Prompt, set environment java_home

set java_home=C:\Program files (x86)\Java\jre1.8.0_65 (LibreOffice 32 bits) set java_home=C:\Program files\Java\jre1.8.0_65 (LibreOffice 64 bits)

notice: path your java

5) In Prompt, run "path\LibreOffice\program\soffice.exe"

6) exit cmd.exe

Run fine in windows xp sp3 32 bits, jre 1.8.0_65 and LibreOffice

edit flag offensive delete link more

answered 2015-08-03 21:43:50 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I solved the problem system Windows 7 Ultimate SP1 64 bit:

  1. In Control Panel, revealed hidden folders.
  2. Closed LibreOffice and deleted the users\your folder\aptdat\roaming\LibreOffice folder.
  3. Installed the latest 32 Bit Java.
  4. Opened LibreOffice, left click on Tools-Options-Advanced, you should see in the windows 2 versions of the latest 1.8.0_51 Java, select the 32 Bit version as LibreOffice is installed into Program Files (x86) folder.
  5. Note it shows you that Java.exe is located in Program Files\Java no it isn't! It's there but in Program Files\Java\jre1.8.0_51\
  6. Left click on Parameters and type C:\Program Files (x86)\Java\jre1.8.0_51\java.exe and click Add.
  7. Close and Reopen LibreOffice, now you will be able to add Extensions.
edit flag offensive delete link more


I had a problem with the path variable and learned that in C:\Program Data\Oracle\Java\Javapath\ are three SYMLINK pointing to java.exe, javaw.exe and javaws.exe

What's important is that this SYMLINK are created by every java actualization. Therefore is preferable to point to that place. Any way, the path variable will send LO to that place if looking for java.

Denis J Navas gravatar imageDenis J Navas ( 2016-09-21 08:49:30 +0100 )edit

answered 2013-04-11 12:06:52 +0100

I seem to be having the same problem on Linux (Mint 14; Kernel 3.5.0-17) running LibreOffice

Looking at the package manager I seem to have mostly JRE6 components installed despite the package billing itself as a JRE7 package: icedtea-plugin (removed), gcj-jre (installed), icedtea-6-jre-cacao (installed), libgcj13 (installed), gcj-4.7-jre (installed), gcj-jre-headless (installed), gcj-4.7-jre-lib (installed), libgcj-common (installed), openjdk-6-jre-headless (installed), openjdk-6-jre (installed), icedtea-6-jre-jamvm (installed), openjdk-6-jre-lib (installed), gcj-4.7-jre-headless (installed), icedtea-7-plugin (removed), libgcj13-awt (installed), default-jre-headless (installed), openjdk-7-jre (removed), gcj-4.7-base (installed).

Any thoughts?

edit flag offensive delete link more

answered 2012-09-07 06:31:13 +0100

Thank you Timon. I will give it a try and report back. I filed a report at Java on why I did not want the latest version.

edit flag offensive delete link more

answered 2012-09-07 16:40:35 +0100

updated 2012-09-07 16:41:49 +0100

Just wanted to add I heard back from java after filing a report. They said it is a Libre Office bug and pointed me to this thread.

edit flag offensive delete link more

Question Tools


Asked: 2012-09-07 05:17:16 +0100

Seen: 49,180 times

Last updated: Aug 03 '15