Extension Installation Could not create Java Implementation Loader

I am unable to install many extensions due to the error ‘Could not create Java Implementation Loader’. I have rechecked the java path etc and not having any luck. I tried un-checking the ‘use java runtime’ and that did not help. I would also like to know how to remove extensions that came bundled-I do not nee all the language extensions that are installed. Perhaps that is not possible. USing LibreOffice on Vista. Is it because I have Java tm 7 update 5 and JavaFX 2.1.1 installed? Thanks in advance.

LibO support Java 7, but (especially on 64-bit Windows) you might receive warnings about the Java version being defective. In that case, download and install the most current JRE 6 version http://www.java.com/java6download/. Make sure you get the file “Windows x86 Offline (32-bit)”. Then configure LibO to use it at “Tools - Options - LibreOffice - Java”

A bit late maybe, but I suffered from the same. I could resolve it by selecting “Tools - Options… - LibreOffice - Advanced” and then selecting one of the possible JRE’s that were installed on my computer (none were selected by default). I’m using LO

@Juul I registered just to say that 5 years later on LO V6.2.4.2 You fixed my problem, Thank you!!!

@Juul, many thx, I was able to solve the problem with your instructions.

To avoid confusion, the exact error message is “Could Not Create Java Implementation Loader” (“loader”, not “folder”).

We now have a source-level analysis here.

The most successful workarounds are described here it seems.

Thanks. I have edited the question for clarity.

Thank you Timon. I will give it a try and report back. I filed a report at Java on why I did not want the latest version.

Well, I uninstalled the existing java, then installed java6. So far so good. This seems to have done the trick. Time will tell. Thank you for your help!

You are welcome

Just wanted to add I heard back from java after filing a report. They said it is a Libre Office bug and pointed me to this thread. https://bugs.freedesktop.org/show_bug.cgi?id=50371

I seem to be having the same problem on Linux (Mint 14; Kernel 3.5.0-17) running LibreOffice

Looking at the package manager I seem to have mostly JRE6 components installed despite the package billing itself as a JRE7 package:
icedtea-plugin (removed), gcj-jre (installed), icedtea-6-jre-cacao (installed), libgcj13 (installed), gcj-4.7-jre (installed), gcj-jre-headless (installed), gcj-4.7-jre-lib (installed), libgcj-common (installed), openjdk-6-jre-headless (installed), openjdk-6-jre (installed), icedtea-6-jre-jamvm (installed), openjdk-6-jre-lib (installed), gcj-4.7-jre-headless (installed), icedtea-7-plugin (removed), libgcj13-awt (installed), default-jre-headless (installed), openjdk-7-jre (removed), gcj-4.7-base (installed).

Any thoughts?

I solved the problem system Windows 7 Ultimate SP1 64 bit:

  1. In Control Panel, revealed hidden
  2. Closed LibreOffice and deleted the
    users\your folder\aptdat\roaming\LibreOffice
  3. Installed the latest 32 Bit Java.
  4. Opened LibreOffice, left click on
    Tools-Options-Advanced, you should
    see in the windows 2 versions of the
    latest 1.8.0_51 Java, select the 32
    Bit version as LibreOffice is
    installed into Program Files (x86)
  5. Note it shows you that Java.exe is
    located in Program Files\Java no it
    isn’t! It’s there but in Program
  6. Left click on Parameters and type
    C:\Program Files
    (x86)\Java\jre1.8.0_51\java.exe and
    click Add.
  7. Close and Reopen LibreOffice, now
    you will be able to add Extensions.

I had a problem with the path variable and learned that in C:\Program Data\Oracle\Java\Javapath\ are three SYMLINK pointing to java.exe, javaw.exe and javaws.exe

What’s important is that this SYMLINK are created by every java actualization. Therefore is preferable to point to that place. Any way, the path variable will send LO to that place if looking for java.

  1. exit LibreOffice and quickstart.exe

  2. run cmd.exe (Prompt)

  3. In Prompt, delete file “%appdata%\LibreOffice\4\user\user\extensions\buildid”

  4. In Prompt, set environment java_home

set java_home=C:\Program files (x86)\Java\jre1.8.0_65 (LibreOffice 32 bits)
set java_home=C:\Program files\Java\jre1.8.0_65 (LibreOffice 64 bits)

notice: path your java

  1. In Prompt, run “path\LibreOffice\program\soffice.exe”

  2. exit cmd.exe

Run fine in windows xp sp3 32 bits, jre 1.8.0_65 and LibreOffice