Ask Your Question
0

How to set after text indent on lists using styles [closed]

asked 2015-09-08 14:52:17 +0200

luiz_borges gravatar image

updated 2015-09-08 21:30:01 +0200

Alex Kemp gravatar image

If I create a paragraph style with a after text indent on the text, and later create a bullet list on that style, it doesn't respect the after text indent rules. I have to manually set it in the custom paragraph settings. Why is that? How can I make it work?

C:\fakepath\list with indent.odt

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2020-08-25 10:54:25.195300

2 Answers

Sort by » oldest newest most voted
1

answered 2015-09-12 21:49:14 +0200

LKeithJordan gravatar image

Before I begin, I should make something clear. I am a Microsoft Office power user, but I am still a newbie to LibreOffice (LO 5). That said, I have looked at your file and tested some ideas. Here are my conclusions:

CONCLUSION 1
Bullets are their own style. This is why you cannot expect them to follow your custom paragraph style.

CONCLUSION 2
You can adjust the right-margin stop on the ruler, or more granularly adjust the paragraph formatting properties to indent the right margin of the bullet.

CONCLUSION 3
You can select a group of bullets and adjust the right-margin stop for the selection. However, new bullet list items either appended or inserted will not retain the right-margin stop setting.

CONCLUSION 4
You can create a custom list style with the desired right-margin stop and apply it to the new bullet items. However, the new setting for the right-margin stop will not become effective for those items.

CONCLUSION 5
I believe this is a programming error.

SUGGESTION
I suggest you report this as a bug. Before you do, perhaps someone else here in the forum can better shed light on this situation.

edit flag offensive delete link more

Comments

Agree with you, but with a limitation. The styles can be mixed as the next answer show, but also reveal what you are suspecting. Is cumbersome the use of list styles. Ths is not an exclusive LibreOffice problem. Office by Microsoft, also is plagued with the same difficulties.

I rather think, that we as users must ask for a clarification not only about were the list styles are configured, but also how they are suposed to be used, because this is not clear at all in published manuals.

Denis J Navas gravatar imageDenis J Navas ( 2018-04-16 01:10:49 +0200 )edit
1

answered 2015-09-13 07:04:49 +0200

pierre-yves samyn gravatar image

Hi

To make it work I do not create my bullets by the button on the toolbar but applying a specific paragraph style as in the Bullet.odt attached.

The paragraph style List is modified from the reference style:

  • Indents & Spacing tab: before text & first line
  • Outline & Numbering tab, Numbering Style: select one in the listbox

This allows also to modify the presentation of all lists by modifying only the list style (to change bullet, use an image, etc.)

Regards

edit flag offensive delete link more

Comments

My problem is in the Indent "after text", this I can't set with styles, just manually.

luiz_borges gravatar imageluiz_borges ( 2015-09-14 19:07:24 +0200 )edit

I had understood your problem. In the Bullet.odt attached document, try to apply Paragraph Style List on the first or last paragraph. You will see that the desired effect is achieved as I said.

pierre-yves samyn gravatar imagepierre-yves samyn ( 2015-09-15 08:45:40 +0200 )edit

Now I understood what you meant. It kind of works, but it is also limiting. In my document I have two main paragraph styles "Body of text" and "Samples" (this on is indent before and after). On both of those I apply 3 different list styles (Bullet, Filled Box, Empty Box). If I use your method I would have to have at least 4 extra paragraph styles to account for the lists, and worse, those paragraph styles don't work with multi-level lists (try to increase the level of the list, it doesn't work)

luiz_borges gravatar imageluiz_borges ( 2015-09-15 19:12:23 +0200 )edit

Indeed this workaround is not effective in this case. Sorry ...

I did not find a bug report on this issue (quick search it is true). May I suggest you create one ...?

pierre-yves samyn gravatar imagepierre-yves samyn ( 2015-09-16 09:23:52 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2015-09-08 14:52:17 +0200

Seen: 748 times

Last updated: Sep 13 '15