Ask Your Question
0

Prevent text overflow in other cell

asked 2015-10-16 15:26:52 +0200

bakenoor gravatar image

I've been trying but can't prevent text from overflowing in the other cell,

right now, my case is

image description

and I want this:

image description

What is the option for Libre Calc, thank you

edit retag flag offensive close merge delete

Comments

Same question here.

SlashV gravatar imageSlashV ( 2016-08-16 00:24:26 +0200 )edit

Similar questions from time to time. The one usable workaround is the blocking helper column with some kind of whitespace as @Mike Kaganski suggested. Also works with hidden column. (May balloon file size if applied to large ranges. An example file with no content except one blocking column D:D has about 1MB.)
A real solution would require a new alignment specificator like Crop in addition to the already implemented Wrap and Shrink.... I couldn't find a related feature request.

Lupp gravatar imageLupp ( 2018-09-06 14:25:38 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2017-10-26 12:33:35 +0200

johan gravatar image

I found this question still isn't answered properly when googling. The solution I found: Select the cells -> format cells -> alignment -> text alignment -> horizontal -> set to 'filled'

edit flag offensive delete link more

Comments

This isn't a proper answer. While this workaround might work in some cases, it will change representation of cells with short text (try with a cell with text abc).

More reliable is creating a new column between A and B, filling it with e.g. 0, and hiding it. Of course, it's a workaround, too.

Mike Kaganski gravatar imageMike Kaganski ( 2017-10-26 13:45:33 +0200 )edit
0

answered 2018-09-06 12:21:17 +0200

A workaround here:

Select the cell -> format cells -> alignment -> Properties-> Tick Wrap text automatically, then you'll see

C:\fakepath\Deepin 截圖_選取範圍_20180906175606.png

change the height of the cell to the default value, then you'll see

C:\fakepath\Deepin 截圖_選取範圍_20180906175711.png

and go to format cells -> alignment -> text alignment -> vertical -> set to 'Top'

C:\fakepath\Deepin 截圖_選取範圍_20180906181426.png

The long text actually wrapped into multi-lines, and we can adjust the cell's height to "hide" below lines.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-10-16 15:26:52 +0200

Seen: 2,356 times

Last updated: Sep 06 '18