Ask Your Question
0

LibreOffice requires a Java runtime environment (JRE) to perform this task. Please install a JRE and restart LibreOffice.

asked 2015-10-24 23:51:50 +0200

TheDatabaseGuy gravatar image

updated 2015-10-29 21:04:08 +0200

Alex Kemp gravatar image

I'm running: Base as part of LibreOffice Version: 5.0.2.2 Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe Under OS X 10.11.1 With Java (Version 8 Update 65) installed

I'm getting "LibreOffice requires a Java runtime environment (JRE) to perform this task. Please install a JRE and restart LibreOffice." when I try to open a table.

Does anyone know what the problem is and, if I'm running the wrong version of LibreOffice or Java, let me know which version I should be running and when I can get it from?

Thanks all.

edit retag flag offensive close merge delete

Comments

I got this same message when I clicked on an Excel command button but there needs to be an answer here by a developer. Do I need a JRE or not and if I do, under what circumstances? LO looks like an excellent product but as far as I can see the support in forums is miserable. If there are, shall we say, shady areas, then users just need to know that. If I can't find these basic answers I'll have to bail out on the product

jobowo gravatar imagejobowo ( 2016-09-30 23:01:14 +0200 )edit

Me too, for sure!! WikiHelp of no use (especially for BASE. Just downloaded LibreOffice and my first experience is NOT joyful. No "Getting Started" at all. What else will I need to get LO working properly? I will now install the latest Java and pray I will get some luck on using LO.

WesselsJ gravatar imageWesselsJ ( 2017-08-02 22:18:54 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-10-29 14:40:15 +0200

jay Arr gravatar image

updated 2015-11-08 08:00:55 +0200

Not that it's much help but I have a BASE application that I've been developing over the last 6 months with various versions of LO and OSX.

It runs fine with LO Version: 5.0.2.2 Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe

and OSX 10.10.5 and with Apple's JRE 1.6.0_65

but the identical application does NOT work with

the same LO Version: 5.0.2.2 Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe

and OSX 10.11.1 running with either Oracle's JRE 1.8.0_60 or 1.8.0_65

it just hangs mysteriously after startup it seems as if the BASE macro startup code (I'm using a split database) does not complete and I have to do an OSX FORCE QUIT.

I am going to revert this combination tho Apple's JRE and see if it works and will report back here

ADDENDUM I have tried installing this Java for OS X 2015-001 in an attempt to get things working - but it doesn't!

I note that there is at least one Bug 94672 that asserts OSX10.11 & LO 5.02 do NOT work together.

And problems have also been reported in this forum here. Incidentally I have tried deleting my user profile as suggested by the link - it did not work.

You may learn more about JAVA and OSX 10.11 here: Apple Java 6 for 10.11

It seems that 10.11 has dropped JAVA 10.6 (!)

Meanwhile I am reverting to my OSX 10.11 machine to 10.10.5 (I don't need the so called improvements)

UPDATE: from Bugzilla - Bug 94716

When LibreOffice on OS X 10.10 or 10.11 and LibreOffice loads Oracle's Java 1.8.x via JNI, the JVM terminates LibreOffice. This bug occurs only when only Oracle's JDK or JRE are installed and Apple's Java is not installed.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-10-24 23:51:50 +0200

Seen: 4,953 times

Last updated: Nov 08 '15