Ask Your Question
0

Problem w/ Windows 10 indexing .odt content for File Explorer search function

asked 2015-11-26 05:30:54 +0100

Lone Peregrine gravatar image

updated 2015-11-26 08:11:25 +0100

Alex Kemp gravatar image

My LibreOffice version is 4.4.5.2 and I am using 64-bit Windows 10. The language of each is English and the only component I am really concerned with for this is Writer.

Here is the issue: My File Explorer searches fail to turn up valid results of .odt content. Although others have run into problems similar to mine, I felt my situation was unique enough (and I was unable to find a solution from other threads) to warrant asking this question anew. The closest case to mine I could find was this from one of our OpenOffice chums, but it unfortunately proved unhelpful because of the poster's good fortune.

I have ensured that the folder within which I am searching has the proper settings (specifically by making sure "Allow files in this folder to have contents indexed in addition to file properties" is checked). Under Windows 10's Indexing Options, I have ensured that the proper directory is indexed (which I also rebuilt), and under the Advanced menu in the File Types tab, I have ensured that .odt is checked and its radio button for "Index Properties and File Contents" is selected. None of these has solved the problem.

With indexing turned on, conducting File Explorer searching for content in the formats of .docx and .txt has been successful--it's just the .odt file format which seems to have a problem. However, searching for the words in the title of .odt files has turned up accurate results. I know that the .odt file content is not being indexed because when I disable relying on the index for the File Explorer searches, the content from .odt files will actually turn up in subsequent searches.

Some who ran into this problem in the past used something called IFilter, which I'm honestly not very familiar with, but it seems to have become outdated and unsuitable since Windows 8. I couldn't find much of anything in a cursory search of IFilter in conjunction with Windows 10, which has only strengthened my suspicion that it is not a viable path.

I appreciate any and all help to assist me in resolving this problem. It has proven both resilient and frustrating so far, but I cling to the hope that this foe will yet be conquered!

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2015-11-26 08:52:06 +0100

Alex Kemp gravatar image

updated 2015-11-26 08:57:43 +0100

Hi Lone Peregrine

This is the M$ info on iFilters; it's unlikely to help you:
https://msdn.microsoft.com/en-us/library/windows/desktop/dd940431%28v=vs.85%29.aspx

I think that this reply from answers.microsoft.com may help:

The OST is not crawled by the indexer as other files are. Rather the indexer requests content from Outlook via URI and then indexes the results.

[Note: "OST" refers to '.ost' files, which are "Offline Outlook files"]

The possible clue as to how to do this comes at this lifehacker article ("Choose Which File Extensions Can Be Searched By Content"):

  1. go to the Start Menu
  2. search for "Indexing Options"
  3. Choose the top result that comes up and then click the Advanced button
  4. Under the File Types tab, add ODT to the list (if not already there)
    (it will need to be connected to LO as the program that it is associated with, as to be used with ODT files in the same way that Outlook is used with OST files)
    image description

Extra:

The ODT, ODS, etc. files are all simple Zip files + can be opened by any standard ZIP app. If the above does not work, then--in the absence of a proper iFilter for the file--connecting it as a ZIP file may also work.

If this helps then please tick the answer (✔)
...and/or show you like it with an uptick ()

edit flag offensive delete link more

Comments

As I wrote in the original post, I've already done what you described concerning Indexing Options. Right now the only successful option is simply to disable using the index for searches.

Lone Peregrine gravatar imageLone Peregrine ( 2015-11-27 06:23:18 +0100 )edit

I have this same problem, although you can see that I have asked for a different solution here. I have a question for Alex, or anyone else who might know. Above, Alex says to associate LO files, now associated with the "Plain Text Filter", with LO or an unziper. How? My files are correctly associated to open on a click, but I've found nothing to change the filter settings, and I've looked hard.

AHoerner gravatar imageAHoerner ( 2017-10-22 05:47:07 +0100 )edit
0

answered 2017-10-22 06:28:53 +0100

AHoerner gravatar image

Hi Lone Peregrine! This info is not an answer to the exact question you asked, but it did helped me with a very similar problem. The Copernic desktop search seems to index and find OO, LO, and MS files with comparable ease. I am still using the free version, with an annoying file number limit (75,000) that only amounts to about a fifth of my files, but by concentrating the bulk of my LO files in a few directories and excluding most of the others I've been able to make do with a two search systems solution. It is a kludge, and sooner or later I'll solve the Windows search problem or buy the full Copernic license ($35, single user). But in the meantime I suspect you might find it an improvement over unindexed search.

It's too bad it, or something like it (DocFetcher? I also spent some time using DF -- lightning-fast, very capable (RegEx! Take that, Windows1), but with an interface that is less intuitive and harder to use) can't just be bundled with LO. If it can't. Maybe LO's front end/user experience gurus could build a better interface to the DocFetcher back end?

Just a thought.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-11-26 05:30:54 +0100

Seen: 1,949 times

Last updated: Oct 22 '17