Ask Your Question
0

I install Java but Libreoffice keeps asking for it

asked 2015-12-12 19:59:37 +0100

PaulFrederik gravatar image

updated 2016-03-12 19:19:22 +0100

Alex Kemp gravatar image

I click "solver" and get the message

LibreOffice requires a Java runtime environment (JRE) to perform this task. Please install a JRE and restart LibreOffice

Simultaneously, I get another popup saying

To use the "java" command-line tool you need to install a JDK.
Click "More Info..." to visit the Java Developer Kit download website.

So I click "More info" and it takes me to the java website http://www.java.com/en/download/mac_d... and I click install. Afterwards, I click on the "OK" button of the LibreOffice requires Java message and LibreOffice crashes. I assume this is so I don't have to restart LibreOffice manually.

I then click "solver" and get the same message again. I've also restarted my computer to no effect.

Any ideas?

(Mac OS X 10.11.2, LibreOffice version: 5.0.3.2, Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75, Locale: en-US (en.UTF-8))

edit retag flag offensive close merge delete

Comments

Ok, in the moderation queue now for 29 hours, so I've used python instead. If this ever gets out of moderation (I guess the moderators are busy) I'd be interested to know what the fix is.

PaulFrederik gravatar imagePaulFrederik ( 2015-12-14 01:40:37 +0100 )edit

Thankfully this question is finally out of moderation but it's had no views since I posted it many days ago, so I will give up, and just comment to say that Apple seems to have changed something for Java in El Capitan, and this messes up a lot of software, including LibreOffice. On the bright side, it forced me to learn the great power of scipy.optimize in python, and I will be using this for future projects too.

PaulFrederik gravatar imagePaulFrederik ( 2015-12-17 01:34:36 +0100 )edit

@paul how did you solve this problem?

pnishad gravatar imagepnishad ( 2016-02-15 11:51:35 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2015-12-27 16:54:38 +0100

TheDatabaseGuy gravatar image

It's possible you need Apple's Legacy Java installed.

You can find it here: https://support.apple.com/kb/dl1572?l...

It's version 6 and it require for certain Java applications on Mac.

I've got both version 6 and 8 installed so don't know which my copy of LO is using!

edit flag offensive delete link more

Comments

I installed the Legacy Java in the link.. Didn't help :(

pnishad gravatar imagepnishad ( 2016-02-15 11:50:13 +0100 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2015-12-12 19:59:37 +0100

Seen: 1,529 times

Last updated: Dec 12 '15