Ask Your Question
0

How to change default style in Writer text boxes?

asked 2015-12-24 09:39:31 +0100

Antonello Lobianco gravatar image

updated 2015-12-24 12:42:36 +0100

Alex Kemp gravatar image

In writer [4.8.2 on Linux], how can I change the default formatting of the text boxes (the ones obtained clicking the "AI" button on the toolbar - see screenshot), e.g. from Liberation Serif 12 black to Liberation Sans 10.5 red ?

I tried changing the default style, but that would change only the formatting of paragraphs outside the box, not the formatting of text in the boxes.

screenshot

Regards, Antonello

edit retag flag offensive close merge delete

Comments

[meta] Why "This post is awaiting moderation" ? (there should be a link to a minimum of description of what's the problem)

Antonello Lobianco gravatar imageAntonello Lobianco ( 2015-12-24 09:41:10 +0100 )edit

Incidentally -- if you hack the ODT's content.xml file and put a paragraph style onto the paragraph nodes inside the text box, LibreOffice will display and handle them correctly!

It's only that the LibreOffice GUI does not allow you to access this option.

jamshark70 gravatar imagejamshark70 ( 2017-09-10 10:33:53 +0100 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2015-12-24 14:13:15 +0100

pierre-yves samyn gravatar image

Hi

If what you want is to change the default style for not having to redefine the font for the next text box, I think it is not possible, sorry... The simplest may be to copy a text box already defined and just change the text.

Regards

edit flag offensive delete link more

Comments

Refer the question here.

oweng gravatar imageoweng ( 2015-12-25 11:12:35 +0100 )edit
0

answered 2018-12-01 22:26:05 +0100

Yes, the character font effects will change color of fonts in a tech box

edit flag offensive delete link more
0

answered 2015-12-24 12:59:25 +0100

Alex Kemp gravatar image

Hi Antonello

Use the Format menu to change text properties:-

  1. Select the text that you wish to change
  2. (menu):FormatCharacter...Font Effects (tab)→Font color
  3. click OK

The above works equally well on text outside the Text box. It is called "Direct formatting" & can be cleared back to the defaults for the Style in effect with Ctrl+M.

If this helps then please tick the answer (✔)
...and/or show you like it with an uptick ()

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-12-24 09:39:31 +0100

Seen: 1,332 times

Last updated: Dec 01 '18