Ask Your Question
0

Slow spreadsheet rendering LibreOffice 5.0.4.2

asked 2016-01-31 01:41:40 +0100

Arch Murphy gravatar image

updated 2016-03-10 11:43:48 +0100

Alex Kemp gravatar image

I recently installed Fedora 23 and LibreOffice 5.0.4.2 on new hardware (8 core 4.7GB AMD 16GB RAM with Nvidia NVS 810 using Nvidia proprietary driver V352.63).

Spreadsheet pages now render and scroll very slowly some exceeding 2 seconds. The same spreadsheets worked fine on the previous system (FC18 LibreOffice 3.6.7.2). Other applications such as browsers and proprietary applications seem to work ok.

I am wondering it there is some configuration issue with the LibreOffice version I am using, such as graphics library setup, which could cause the slow rendering?

Grateful for any help. Arch

edit retag flag offensive close merge delete

Comments

Please try resetting the user profile, sometimes solves strange issues. https://wiki.documentfoundation.org/U... Usually it's enough renaming/deleting the file "user/registrymodifications.xcu", it affect all the options in Menu/Tools/Options, and the files "user/basic/dialog.xlc" and "scrip.xlc" are overwritten, additionally custom colors in "user/config/standard.soc" are lost.

m.a.riosv gravatar imagem.a.riosv ( 2016-01-31 18:18:34 +0100 )edit

Also try turning off / confirming OpenGL as v5.x is seeing quite a bit of work in this area.

oweng gravatar imageoweng ( 2016-02-01 06:16:15 +0100 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2017-03-22 16:25:20 +0100

kjedrz gravatar image

Hi, I've had similar problem with my new laptop (i7-6500U) and LibreOffice 5.3.1.2 (x64) (previous 5.2.x was the same problem) turning ON full OpenGL rendering and OpenCL solve the problem (Tools > Options > LibreOffice > View > Enable: Full OpenGL rendering, and Tools > Options > LibreOffice > OpenCL > Enable: Allow OpenGL usage ... or sth similar in meaning - i don't use english version).

edit flag offensive delete link more
0

answered 2016-05-27 11:50:03 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi Libreoffice's users! I had the same problem, in a sheet with 400 lines. I had tried to modify memory configuration, copy the sheet in a new document, delete lines... Slow again. The solution (in my case): delete all conditional configuration: Format/Conditional format/Manage (sorry if it is wrong, my menu is not in English) In my case, it were the same condition to many times, duplicated for the same cells, I do not why. I hope it can help someone.

Thank you. (Sorry for my poor English)

Long life to this free project!

edit flag offensive delete link more

Comments

This worked for me too. Thanks!

psychodox gravatar imagepsychodox ( 2017-04-10 08:57:07 +0100 )edit
0

answered 2016-04-17 15:50:45 +0100

Hi! Please try: Tools > Options > LibreOffice > View > disable "Use anti-aliasing".

I am using LibreOffice 5.1.2.2 and it solved my problem. Cheers!

edit flag offensive delete link more

Comments

But don't disable hardware acceleration or you could end up like me: No Libre Office programs will come up leaving me in the catch-22 where I can't re-enable hardware acceleration and use LibreCalc despite the painfully slow scrolling. PS: disabling anti-aliasing didn't fix it and LibreOffice won't come up even in safe mode..

jabowery gravatar imagejabowery ( 2017-10-04 22:47:45 +0100 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2016-01-31 01:41:40 +0100

Seen: 3,390 times

Last updated: Mar 22 '17