Slow spreadsheet rendering LibreOffice 5.0.4.2

I recently installed Fedora 23 and LibreOffice 5.0.4.2 on new hardware (8 core 4.7GB AMD 16GB RAM with Nvidia NVS 810 using Nvidia proprietary driver V352.63).

Spreadsheet pages now render and scroll very slowly some exceeding 2 seconds. The same spreadsheets worked fine on the previous system (FC18 LibreOffice 3.6.7.2). Other applications such as browsers and proprietary applications seem to work ok.

I am wondering it there is some configuration issue with the LibreOffice version I am using, such as graphics library setup, which could cause the slow rendering?

Grateful for any help.
Arch

Please try resetting the user profile, sometimes solves strange issues.
https://wiki.documentfoundation.org/UserProfile
Usually it’s enough renaming/deleting the file “user/registrymodifications.xcu”, it affect all the options in Menu/Tools/Options, and the files “user/basic/dialog.xlc” and “scrip.xlc” are overwritten, additionally custom colors in “user/config/standard.soc” are lost.

Also try turning off / confirming OpenGL as v5.x is seeing quite a bit of work in this area.

Hi!
Please try: Tools > Options > LibreOffice > View > disable “Use anti-aliasing”.

I am using LibreOffice 5.1.2.2 and it solved my problem.
Cheers!

But don’t disable hardware acceleration or you could end up like me: No Libre Office programs will come up leaving me in the catch-22 where I can’t re-enable hardware acceleration and use LibreCalc despite the painfully slow scrolling. PS: disabling anti-aliasing didn’t fix it and LibreOffice won’t come up even in safe mode…

Hi Libreoffice’s users!
I had the same problem, in a sheet with 400 lines.
I had tried to modify memory configuration, copy the sheet in a new document, delete lines… Slow again.
The solution (in my case): delete all conditional configuration: Format/Conditional format/Manage (sorry if it is wrong, my menu is not in English)
In my case, it were the same condition to many times, duplicated for the same cells, I do not why.
I hope it can help someone.

Thank you. (Sorry for my poor English)

Long life to this free project!

This worked for me too. Thanks!

Hi, I’ve had similar problem with my new laptop (i7-6500U) and LibreOffice 5.3.1.2 (x64) (previous 5.2.x was the same problem) turning ON full OpenGL rendering and OpenCL solve the problem (Tools > Options > LibreOffice > View > Enable: Full OpenGL rendering, and Tools > Options > LibreOffice > OpenCL > Enable: Allow OpenGL usage … or sth similar in meaning - i don’t use english version).