Ask Your Question
0

Automatic field updates not working [closed]

asked 2012-10-03 21:47:25 +0100

Don HL gravatar image

I think I have Writer set properly; it looks to me like my fields should update when I reload the program, but they do not. The F9 key seems to have no effect. Anyone have an idea about what I'm doing wrong? When I go into Tools/Options/Writer/General, it shows automatic updating of links and fields, but it doesn't happen. Thanks in advance.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-11-03 23:17:37.607065

Comments

What sort of fields are you having problems with?

w_whalley gravatar imagew_whalley ( 2012-10-03 22:31:31 +0100 )edit

I have date and time field in a document header so I can keep track of drafts, and I want them to update each time I open the document.

Don HL gravatar imageDon HL ( 2012-10-04 12:31:47 +0100 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2012-10-04 14:03:26 +0100

w_whalley gravatar image

Date and time fields come in two varieties, Fixed and Variable. The default is Fixed. Right-click on your field and choose Fields on the context menu then choose the option that is not fixed. Then F9 will then update your fields and automatic updating will work.

To insert the variable date field directly here is a link to the relevant help for Inserting a Fixed or Variable Date Field.

edit flag offensive delete link more
0

answered 2013-07-15 18:38:19 +0100

ddsjoe gravatar image

This does NOT work for me. When I click on "date," instead of a date appearing in my document, "Date (fixed)" appears. This is of no use to me, obviously.

edit flag offensive delete link more

Comments

Go to Insert > Fields > Others (Ctrl-F2) There are various options under the Document and DocInformation tabs.

Prince gravatar imagePrince ( 2014-07-16 05:49:58 +0100 )edit

Insert-Fields, either the date or the time and then where it will say date or time (fixed) - highlite that and press the keyboard control button plus F9. The .date or time will now show.

jon.harker gravatar imagejon.harker ( 2016-08-03 13:14:05 +0100 )edit

I have the same problem and it extends to ALL of the auto-update functions. NONE of the preceding remedies worked. I am using a Macintosh laptop, I have also updated LibreOffice and there is no improvement. Mac laptops also don't have F9 (etc) keys.

Fenton gravatar imageFenton ( 2016-10-09 03:45:07 +0100 )edit
0

answered 2012-10-04 17:58:42 +0100

Don HL gravatar image

Beautiful. Thanks so much.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-10-03 21:47:25 +0100

Seen: 6,186 times

Last updated: Jul 15 '13