Automatic field updates not working

I think I have Writer set properly; it looks to me like my fields should update when I reload the program, but they do not. The F9 key seems to have no effect. Anyone have an idea about what I’m doing wrong? When I go into Tools/Options/Writer/General, it shows automatic updating of links and fields, but it doesn’t happen.
Thanks in advance.

What sort of fields are you having problems with?

I have date and time field in a document header so I can keep track of drafts, and I want them to update each time I open the document.

Date and time fields come in two varieties, Fixed and Variable. The default is Fixed. Right-click on your field and choose Fields on the context menu then choose the option that is not fixed. Then F9 will then update your fields and automatic updating will work.

To insert the variable date field directly here is a link to the relevant help for Inserting a Fixed or Variable Date Field.

Beautiful. Thanks so much.

This does NOT work for me. When I click on “date,” instead of a date appearing in my document, “Date (fixed)” appears. This is of no use to me, obviously.

Go to Insert > Fields > Others (Ctrl-F2)
There are various options under the Document and DocInformation tabs.

Insert-Fields, either the date or the time and then where it will say date or time (fixed) - highlite that and press the keyboard control button plus F9. The .date or time will now show.

I have the same problem and it extends to ALL of the auto-update functions. NONE of the preceding remedies worked. I am using a Macintosh laptop, I have also updated LibreOffice and there is no improvement. Mac laptops also don’t have F9 (etc) keys.