Ask Your Question
2

Libre Office gui has wrong font. Bug?

asked 2016-03-20 13:53:09 +0200

rcheetah gravatar image

updated 2016-03-20 14:05:58 +0200

Hello Community,

my LibreOffice 5 has a very stupid font for the headings. It’s something like "Impact" and it’s really hard if not impossible to read. I’m working on a Mac OsX 10.11.2 (El Capitan). I tried to completely remove LibreOffice, and then reinstall it, but it’s still the same. Please take a look at the properties menu of the attached screenshot.

http://s30.postimg.org/4j1pwa19t/Wron...

Does anyone have a similar problem on OsX? Can I change the GUI fonts of LibreOffice manually?

edit retag flag offensive close merge delete

Comments

I'm using this build on OSX: Version: 5.1.1.3 / Build ID: f579d750e65277a91cbf19f00b90ad1b257718f9, and it's all good for me. I'm using the version you can get "free" in the AppStore ("LibreOffice Vanilla" from Collabora). Which version have you got? I'm on 10.10.5 Yosemite still.

David gravatar imageDavid ( 2016-03-20 16:38:10 +0200 )edit

I tried this. I completely removed the normal one and installed from the App Store. Problem is still there.

rcheetah gravatar imagercheetah ( 2016-03-20 20:10:41 +0200 )edit

I'm surprised I didn't come across your question when searching for GUI font problems. I have been experiencing this same issue on 10.11.4. The fact that LibreOffice is pulling in the system font 'Gill Sans ExtraBold' instead of 'Impact' on my machine might give credence to the idea that this is a User Profile issue.

coffeecola gravatar imagecoffeecola ( 2016-04-06 01:11:24 +0200 )edit

I have the same exact problem!

http://i.imgur.com/KTK6dEP.png

hectoremilio gravatar imagehectoremilio ( 2016-04-28 05:33:02 +0200 )edit

@hectoremilio, happy to see I am not the only one who is having this issue. I'll let you know if I find a fix.

coffeecola gravatar imagecoffeecola ( 2016-04-29 02:30:55 +0200 )edit

@coffeecola, I have the same problem too. Did you find a fix? I have also posted the issue on StackOverflow here: http://stackoverflow.com/questions/38.... Hope it will lead to something...

Pipo gravatar imagePipo ( 2016-08-01 16:06:10 +0200 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2016-03-20 14:45:12 +0200

Rugslug gravatar image

LO 5.1.2 (and Windows)(Mac should be the same):

Tools Options +LibreOffice Writer Basic Fonts Set all Fonts to the same and your preferred choice.Okay out. Exit LO and restart.

F11 (Styles and Formatting) Check that Default Style Heading etc are the new font. If they are the Font you chose in the options, then you are good.

If they are still the same, perhaps a default template is setting them. See Reset to Default Template. Or you can edit your default template.

edit flag offensive delete link more

Comments

Sorry, I think my question was a little bit unclear. I have no problem with the fonts in documents. My problem is the font used in the whole LO User Interface. Check out this second screenshot:

https://s23.postimg.org/p5jo0wlez/Wro...

In the whole software any dialog "heading" uses this font similar to Impact. Based on Screenshots from the internet I guess the words with this style should just be bold, but in my case, it uses this stupid fun font. Do you see my problem?

rcheetah gravatar imagercheetah ( 2016-03-20 15:22:23 +0200 )edit

I see your problem. I should have clued in with the GUI part. Impact is not a fun font.

Rugslug gravatar imageRugslug ( 2016-03-20 18:36:09 +0200 )edit

haha xD Okay that fun-font thing was maybe something subjective ^^

rcheetah gravatar imagercheetah ( 2016-03-20 22:27:29 +0200 )edit
0

answered 2016-03-21 09:52:13 +0200

oweng gravatar image

updated 2016-03-21 09:56:25 +0200

This appears to either be a graphics card definition (more likely) or GTK issue (less likely). Refer thread exhibiting same problem under Arch GNU/Linux here. I should add that to force GTK3 use:

$ export SAL_USE_VCLPLUGIN=gtk3

edit flag offensive delete link more

Comments

Sadly, exporting this variable didn’t help, although I started LO in the same Terminal.

rcheetah gravatar imagercheetah ( 2016-03-21 18:24:44 +0200 )edit

Use of GTK3 may require enabling LibeOffice > Preferences > LibreOffice > General > Experimental features. Restart required.

oweng gravatar imageoweng ( 2016-04-05 12:05:15 +0200 )edit
0

answered 2016-03-20 21:20:51 +0200

Regina gravatar image

The user profile has a lot of font replacements settings. Therefore I would first try, whether a new user profile solves the problem. Close all LibreOffice, including quick starter (if such exists on MAC), and then rename your user profile directory. Then restart LibreOffice and you get a new user profile. If that does not help, then you can delete the new one and revert the renaming. I don't know where a user profile is located on a MAC, but you should see it in Tools > Options > LibreOffice > Paths.

edit flag offensive delete link more

Comments

Sadly, this does not work either. Maybe the font itself is corrupt. What Font does LibreOffice normally use in it’s User Interface? Maybe I can check all instances on my computer.

rcheetah gravatar imagercheetah ( 2016-03-20 22:24:44 +0200 )edit

On Windows it uses the font settings of Window for windows and menus, which is "Segeo UI" for me. If you know the name of the font, which is used in the wrong cases, you can replace it in Tools > Options > LibreOffice > Fonts > Replacement Table. (Restart LibreOffice then.)

Regina gravatar imageRegina ( 2016-03-21 01:04:22 +0200 )edit

Nope, didn’t work. Also I guess this will just replace fonts in documents, but not on the Interface, or does it?

rcheetah gravatar imagercheetah ( 2016-03-23 18:26:35 +0200 )edit

On Windows the font-replacement changes the menu fonts too. Perhaps you ask on a Mac forum about the interdependency between OS and applications in regard to window and dialog elements.

Regina gravatar imageRegina ( 2016-03-24 13:20:54 +0200 )edit

ok, so i do have this problem on mac. new user fixes the problem but deleting all libre office preferences in current user (libre office folder in application support) does not. so what do i need to delete further? (on a second note: why do i have to go through a stupid email validation process for ten minutes to be able to ask this?!?)

fuckthisregistration gravatar imagefuckthisregistration ( 2016-09-10 01:04:52 +0200 )edit
0

answered 2019-06-13 06:43:23 +0200

arandor gravatar image

updated 2019-06-13 06:44:42 +0200

I had the same problem and now it is fixed.

The Fix

Open the Font Book application (/Applications/Font Book).

Click on the File menu and select the menu item Restore Standard Fonts…

This will move any fonts you have installed to the folders ~/Library/Fonts (removed) and /Library/Fonts (removed).

The LibreOffice fonts will now display correctly. However, if you need to use the fonts that were uninstalled, then you will have to determine which one(s) are causing the problem.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2016-03-20 13:53:09 +0200

Seen: 2,479 times

Last updated: Jun 13