Libre Office Calc does not use system font on OSX

LibreOffice on Mac OSX 10.11.4

I have been noticing that LibreOffice does not use the system font for headings or active items in the GUI. It seems to be using the font Gill Sans ExtraBold, which ships with Mac OS X.

Is this a bug or is GUI font set somewhere in Preferences?

I though this bug might be related:

The font appears to be the same as that I link in my answer here. A simple export of the variable does not seem effective. This may be because MacOS requires the generic (gen) value, rather than the GTK3 one. I am not near a Mac at present to test this.

EDIT: Use of GTK3 may require enabling LibeOffice > Preferences > LibreOffice > General > Experimental features.

It does appear to be the same issue, but its interesting that the font is different ( Gill Sans ExtraBold v. Impact Regular). I could not find anything for Experimental features under General, but did turn on something by the same name under LibreOffice > Preferences > Advanced > Optional (Unstable) Options. Unfortunately, the GUI is still using Gill Sans after enabling this option and rebooting.
Are you suggesting I should build GTK3 for OS X?

Are you suggesting I should build GTK3 for OS X?

No. That would be a last resort. I am just concerned that the recent GTK3 work being done on LO is either the cause or related. It may, alternatively, be VCL-related. It is a really strange problem. Have a look under LibreOffice > Preferences > LibreOffice > Advanced > Expert Configuration button > do a search for “Gill” to see if there are any related font entries. The UI_SANS VCL entries may also be revealing.

I didn’t manage to find anything that looked like it was pointing to Gill Sans in the Expert Config. Are the values represented the installed fonts LibreOffice looks for when rendering the UI?

Some of the values are preference / substitution lists e.g., use font A, then font B (if font A is not available). Interesting there is no “Gill” value at all.

If I had to guess, LO is not finding any of the listed values and goes to a fallback for bold, which somehow ends up being Gill Sans MT Bold. I’m going to try editing these strings manually with fonts that I know are on my OS. Are these configs documented anywhere?

I had the same problem.

Trashing ~/Library/Application\ Support/LibreOffice and restarting application did the job.

I lost my settings, but I had not used the application much.
So, I guess, my problem was in the preferences files.

Trashing this directory did not work for me. Has anyone found a solution for this yet. This is causing real usability problems.

Not a solution, but a workaround that makes life better: disable Gill Sans Ultra Bold and - in my case at least - LO now using something that looks much more sensible.

Hey, any solution yet? I seem to have the same problem, but the font used consist of rectangles…