Ask Your Question
1

Spellchecker behaves strangely

asked 2016-03-23 14:48:26 +0100

updated 2016-03-23 18:21:40 +0100

C:\fakepath\dict-vec.oxt.docx

as. The linked file is actually an oxt, not a docx!

I have created a venetan spell checker (ISO 639-3 vec) but something strange happens. I am able to set "Default Languages for Documents" in Tools > Options > Language Settings > Languages and it displays correctly the check mark.

I write something. But when I hit F7 a modal is popped out telling me "The spellcheck is complete". I then click on OK and the drop-down of the Text language shows me no languages at all.

Moreover, if I try again to set the default languages for documents the checkmark on Venetian disappears... Anyone has some hints?

This seems to happen whenever I changed the

< prop oor:name="Locales" oor:type="oor:string-list" > < value >it-IT< /value > < /prop >

from it-IT to vec in the dictionaries.xcu.

ps. Unfortunately it seems I cannot link the oxt because "> 3 points required to upload files"...

edit retag flag offensive close merge delete

Comments

You should have enough points now.

oweng gravatar imageoweng ( 2016-03-23 17:58:59 +0100 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2016-03-24 14:06:40 +0100

updated 2016-03-24 17:42:10 +0100

I finally nailed it!!!

Here, in the dictionaries.xcu,

< prop oor:name="Locales" oor:type="oor:string-list" > < value >it-IT< /value > < /prop >

I have to change from "it-IT" to "vec vec-IT", having

< prop oor:name="Locales" oor:type="oor:string-list" > < value >vec vec-IT< /value > < /prop >

I still don't known why it worked that way...

edit flag offensive delete link more

Comments

Strange. vec-IT I can understand but vec vec-IT seems unusual. Thanks for posting back your working configuration.

oweng gravatar imageoweng ( 2016-03-25 01:39:05 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-03-23 14:48:26 +0100

Seen: 38 times

Last updated: Mar 24 '16